Nintendo switch not being recognized by PC, can’t inject payload. Advice needed

Hi there, I bought a switch off of eBay that “wasn’t docking” but worked other than that, the docking was the only issue. After replacing the charging port the switch now docks but I’ve noticed the switch itself doesn’t actually get recognized by my pc.

Things To keep in mind:

  • the cable between the pc and switch is fine
  • I believe the charging port was soldered on correctly
  • the PC charges the switch when connected

Any advice? Has anyone ran into this issue before and fixed it? The reason I would like the switch to be detected is because I’d like to run CFW on it (yes it’s an unpatched unit).

i assume you have install the drivers necessary for the tegrarcmgui ?

Yes, can inject payloads fine with other unpatched switches.

  1. Is it actually in RCM mod ? Take emmc out and start the switch , it will automatically be in RCM mode. Then plug it back in after started

  2. Do you have a usb c breakout boards to check for connectivity between the port and the usb points. What are the resistance of both usb point ? Can you diode the usb c port ?

  3. I would clean the usb c port because flux could be inside.

  1. Taking out the emmc didn’t make a difference.

  2. No I don’t have a breakout board, i’ll buy one right now though.

  3. The port is clean.

Taken out emmc just force it into RCM. If you computer still does not detect then it’s definitely a usb port / usb line / usb filter issue.

I guess just wait for the breakout board then check diode mode.