Nintendo Switch not charging/ no charge icon

Hello first time posting here.
I have a faulty Nintendo Switch.
If I plug a known good battery in the Switch starts and everything works. When i plug the charger there is no charge Icon and battery depletes normal. I opened the Switch and looked for any shorts and i found some under cpu and the caps in the circles on the pictures. Does anyone know what is causing this fault?

Because i can not upload picture or post links here are the endings for the pasteboard images.


please add working links or just make some new posts and you will be granted access to adding pictures and links.

Hi here are the links:
Because i cant post hyperlinks you need to copy and paste them.

These components should be coils so a short across them is normal

Have you checked the usb port and mt92 chip? looks like someone has worked on them

Check that usbc cc lines have no short and are connected, then replace mt92 chip if they are fine

Hi, yes i checked the mt92 chip and the usb port there were no shorts but i still replaced them from a blue screen board which i knew was charging. I also replaced the BQ chip because there is no current going to the battery.
At first there were a blown which i replaced.
There are also some caps which are shorted under the cpu. Somewhere around this position
Cant check rightnow because i am at work.

Does Voltage from the USB-C reach the M92T36 if a charger is pluged in?

Does the battery need to be connected?
I tried without battery and measured where you made the Orange Marks but i dont get any readings. How can i check that the mt92 chip is still god and has a good connection?

Let s start at the USB-C connector.

At any time if the charger is connected at the USB-C, the blue marked pins should show ~15V.
If You can t measure the voltage at this point, You should check for a short to ground.

If You can measure the voltage go up on the line to the fuse (green marked). The fuse is blown if You can t measure continuity through the fuse.

If the fuse is ok and You have a short, I would take the fuse out and check if the short is gone at the USB port and check above the fuse.

Hi Guys, through your help i could figure it out. It was the fuse or a bad contact (because the fuse had continuity) to the mainboard.
I could measure 5v at both side of the fuse but after that there was no current. So i removed the fuse and bridged the pads with solder and it started to charge.
Now i am mad at me because it was the first thing i changed on the board and i unnecessary changed the chips and USB C.
I will order a new fuse (because i lost the one which was on the board :sweat_smile:)
Do you have any tips for soldering the fuse?
Should i use hot air or a small tip on the soldering iron?

Cool. :slightly_smiling_face:

I would use the soldering iron with a bit flux to solder the fuse back.
I usually prepare the pads with a tiny amount of solder so the component I want to solder is lying nearly flat on the board and than tin on side and then the other side. Sometimes I use hotair, if the component isn t soldered nice in place, to align itself.

Hi, here is my final update on my Problem.
I used this fuse:
Also i needed to change the MT92, BQ and PI3USB chips. After that everything works fine now.