NINTENDO Switch takes charge 15V 0.4A,not turn on

client sent me this device only states not turn on. It seems never been attempted.
At the beginning tried with charged battery, not turning on(no backlight, black screen)
I have checked M92T36, no short, BQ24 also ok since 15v goes to BQ ic and 4.2v present.
prob around no luck finding short. The only thing goes wrong IMO is the MAX 77621 under emmc does not have 0.8~0.9v output. No short around that max, and the other max77621 has 0.8v output.

I have tried reball the suspected max77621 but no difference,even replaced it from another donnor board, no difference. Reball MAX77620, no difference.

Any thought is welcome.

Well the 0.41 no screen problem is tricky, I’ve had two like this with no success and @tronicsfix said already that it is not a good news and is often "not fixable "

Without battery, the board takes 15v 0.089A

do not have a switch
but tested right now on a lite with the problem and get 0.05 without battery

Bit of an old post here, but perhaps I can offer some comment for anyone else in this situation.

The MAX77621 located below the EMMC is for the GPU and only fires up in the late stages of the boot sequence when Horizon home screen wants to display.

The other MAX77621 is for the main CPU complex which will fire up as soon as the BPMP load has completed and it appears to be outputting what you need.

At this point you could be suffering a Fuel Gauge failure, EMMC corruption or a problem with one of the rails (3v3, 1v8, Vsys, 1v35, 1v15, 1v1).

1 Like