Nintendo Switch (used to) work but 0.00 Amps

Originally the Switch had a damaged USB port and wouldn’t boot even with a good battery.

I replaced USB port (I had to jumperwire a pad, the 3rd from left to right which should be an info line, in the hidden row), PI3USB (I replaced it because the capacitor north of the chip was shorted, and it’s not anymore) and the switch would boot with a good battery but would show error 2101. That indicates a faulty M92T36 chip according to multiple internet reports.

I replaced M92T36 (I took it from a donor board) and the Switch worked 99% with an externally charged battery. It could boot, play games, connect to internet, read SD, and everything else, the only faults are that it doesn’t recognize USB C cable, does not charge nor does it dock so it’s still unusable unless you change the battery every other day.

This last part is driving me crazy. My USB voltmeter gives 5V and 0 Amps on both sides, with or without the battery attached, with multiple cables. My multimeter says the fuse and the coil are OK (almost 0 resistance, 5V on both sides of fuse and 3.8V on both sides of coil), the voltage lines of 5V (m92) and 3.8V (BQ) reach succesfully both chips but what comes out from them is very little voltage (0.10; 0.01, 0.00 depending on the via) so that would suggest maybe a fault there although I can no longer find shorted capacitors. The point though is that the Switch was perfectly working and that is unusual for a faulty chip, right? I retinned the USB port cable pads and still, 5V but 0 Amps. I tried everything and I’m at a loss.

Thoughts? What can cause a 0.00 Amps current given that somehow the voltage of is transferred from the USB port to the charging chips? Could it be the jumper wire in the hidden row shorting some pads inside the USB c Port? Could it be yet another chip fault that somehow still makes the console function?

I know it’s not easy to help but if you already have experience with 0.00A repairs maybe you can at least direct me into the right path (i.e. bridged pins, faulty IC, etc.)

The Switch does not recognize the cable on both sides (it used to recognize the original charger on one side, but would still not charge, I do not remember what I did when it stopped doing so).

Now I get 2101 error again. All I changed was I put back the 100KOhm piece that connects
to the 9th pin on the north side of m92 (I accidentally lost that one and the one that goes to the 10th pad, which is still missing). Unless I accidentally bridged some pins again (not that I can see), maybe that via works as a “feedback” via and without it my faulty m92 was not being recognized as defective? Or maybe I’m just guessing out of my ass and I need to resolder some stuff.

to be clear, of those twin components, the 10th pad one was and is still missing. the 9th pad one was missing when the console functioned, now that I put it back I get 2101 error again

I have some other motherboards with those two missing, I’m not sure if they used to be installed in older motherboards and are not essential, or if some technician just stole the components to fix my same problem. The 9th pad one looked important as it goes back to a capacitor west of m92 and that’s why I decided to put it back.

To be clear I took the replacement from the pair just southeast of those components from another board because the same ones were missing, from what I gathered they are the same. Either that line checks if the chip itself is working or I did some mistake while soldering, I will rework it later and update the thread. Still, 0.00A has been constant before and after the installment so my main problem still stands.

Voltage on pin 4 is 0.77 V and on pin 6 1.0 V with battery and USB cable on (north side of m92).

From what I’ve gathered on the forum is relevant to the diagnosis?

change the M92T36, with a new one

New M92 will be replaced in a few days as soon as it comes home.

Aren’t the two power voltages to the chip quite low to begin with though?

UPDATE: M92T36 replaced, 100 KOhm resistor replaced, pi3usb replaced.

Switch works and charges but only on one side (and depending on how I place the cable). Haven’t tested docking yet but I’m assuming it doesn’t work since it should require both rows of USB C pins.

I’m starting to think it’s not worth to finish the fix as I would need to check the jumperwired pad, the port, PI3USB and its capacitor only to have docking and double charging. Probably better off selling it as-is since it still works and charges on one side.