Nintendo Switch Won't dock one way


I have a Nintendo Switch V1 which arrived with no power. I discovered PI3USB was defective along with the M92T36. I replaced both and Switch works as expected however won’t dock. Specifically won’t dock in one direction.

I’ve tried two known working official docks and screen turns off and light comes on etc, just no display.

I’ve got a 3rd party USB C hub and it does dock with that in one direction.

I’m at a loss of what to check next. I’ve tried an additional PI3USB with no luck. I’ve checked all filters and they are fine.

I’ve checked over the USB port, it’s factory and looks immaculate with no bent pins etc.

It charges fine in both directions and data is fine both ways also.

My USB-C readings are as follows: -

A12: GND
A11: OL
A10: OL
A9: 0.520
A8: 0.520
A7: 0.81
A6: 0.81
A5: 0.77
A4: 0.520
A3: OL
A2: OL

b12: GND
b11: OL
B10: OL
B9: 0.520
B8: 0.521
B7: 0.81
B6: 0.81
B5: 0.77
B4: 0.523
B3: OL
B2: OL

Any suggestions? Am I missing some really obvious? Any help would be appreciated :slight_smile: