No 1.35v, can't see any data signal in I2C lanes


I got in a switch lite, that supposedly only got a left joystcik swap in a shop. The console was working the first day, but the client returned it to the shop the next because it would not power on. THey then brought it to me.
So far, I have found that it is missing 1.35v, all other voltages (that I know of) are there. There is no visual damage.
I have tried a reflow of the fuel gauge ic, no change.
Removing m92 chip, still no 1.35v.
I have checked for shorts in common areas, nothing.

I know that the 1.35v line is controlled by the SOC, which need to “see” that what it wants is happening. SO something it wants is not happening. I decided to probe the SCL and SDA lines with an oscilloscope, just to see if there was anything happening, but nothing, they both go high (1.8v) and no pulsing.

Shouldn’t there be some I2C communication right before booting? Could the lack of something communication on that line be what’s missing to turn on the 1.35v line?

What I understand about the fuel gauge is that if something is wrong with it, the 1v35 line wont turn on (as well as many other things), but from what I could tell, the only way the SOC knows the fuel gauge is goos is through I2C, so… if theres nothing going on in the I2C, that idicates no fuel gauge detection? Just thinking out loud. I hate replacing bga’s if they aren’t the issue, plus I would need to get some solder balls, as the smallest I have is .55.

Yes that is sound logic but it’s possible a faulty IC is holding it in a high state but hard to say.

Do you have the ability to test the EMMC? (love voltage emmc adapter hooked up to the relevant points)

The fuel gauge can be purchased from legit vendors like mouser etc and are preballed so no messing around needed (and I’d opt for solder paste and stencils for chips this small if your pulling from a donor)

Any indications of board warp? Switch lite is very prone to this due to an utterly terrible case design and I’ve seen boards which behave like this and it’s an SoC/Ram / joint related issue as a result of the warp. Unfortunately if that’s the case then the only solution would be to transfer the SoC and EMMC (and possibly Ram - depending) over to a known good donor board and checking the shell for that same warp (and replacing if so)

Thank you for the reply. I do not have a low voltage emmc reader, but if I’m correct, when it is the emmc, doesn’t it go into RCM mode? My computer does not detect an rcm device, no device at all for that matter. But wish I could read the emmc. And there is no warp at all, it’s actually really been taken care of from the looks of it. I would look into buying the fuel gauge if there was some way I could be sure it was it.
Do you know is there should be data over the I2C line just before the 1.35v rail turns on? I don’t have any working switches here.
Just in case this helps. The guy that did the joycon replacement says, after doing the replacement he tried to turn it on, but it didn’t work, so he unplugged the battery, replugged it in, and then it turned on. But next day the client told him it would not power on.

Usually but it depends on the failure mode, whether it’s completely dead or which partition is bad/corrupt

Does it detect it in any capcity, as in the windows chime or anything or installing drivers etc ?

Unfortunately you’ve exhausted all options in this regard (checking I2C) - more often than not testing surrounding support circuitry will all measure fine and the IC can still be bad, though more often than not it’s physical and you can see it (chips, cracks, dings)

I would imagine there would be as I think we know (and you mentioned earlier) that without the fuel gauge or a bad fuel gauge you won’t get 1V35 present. But on the other hand, SoC will be doing it’s own set of self checks prior to initializing I2C comms for external devices and it it isn’t getting to that stage then no I2C comms woulld be expected, and of course we don’t actually know what the sequence is unfortunately.

Best we can say is this is either an intermittent issue or the guy caused the issue while inside (maybe not unplugging battery when connecting and disconnecting ribbons etc) - Some info on the forum regarding joycon related circuitry which might be worth looking at, sorry I can’t help here as I haven’t fully traced this out on Switch and don’t know how the circuitry differs between regular and lites (though I’d imagine it’s largely the same) - Then failing that taking a very close look at the backlight ribbon and the PCB which it goes via as it’s quite common for this connector or the traces to burn out when people leave the unit on/battery hooked up (If I remember right) and also the backlight driver IC and diode.

I’d also take a good look inside all other connectors and make sure there is no bent pins etc just incase.

afair Switch Lite boards will prompt with board and battery alone, which you should be able to see on a USB current meter.

No, no chime at all.

Exactly what I was thinking, maybe it’s not even getting to the point of doing external checks.

I am doing the current draw test (psu instead of battery), and I only get a current draw of 0.05a at 4.2v. So don’t know what stage it’s stuck at.

Already did that, as I normally don’t trust what people say they have done. No connectors look bad. Aside from the flex going to the daughter board being a little bent, I wouldn’t be able to tell that the switch was ever opened.

So, this is what I got today. It draws 0.05a (instead of 0.2a) from the battery (using a psu) when turned on. My psu was tested the same way on a bad switch board, and it does in fact register 0.2a.

I probed the emmc clock, and when pressing “on” the clock appears for a split second then goes away, the current goes from 0 to 0.05a and stays there. From what I understand, the clock signal should always be there when “on”, even if the emmc were bad or missing. So that’s a new symptom.

I have installed a pico, and got into hekate. I have done a benchmark on the emmc, and everything seems fine there. Battery level also is listed, so fuel gauge should be fine. It will not boot into cfw (as expected).

Ok, so my Secure boot key (SBK) and Device Key are showing up as FFFFFFFFF…, That’s the only odd thing I can find in Hekate, and the fact that Biskeydumper payload will black screen , but that might be because of the version, I haven’t used it in years, so I don’t know if it works on lite versions

Use lockpick_rcm.bin

Thanks, lockpick does work. But still no idea why it’s not booting, I’ll probably try a emmc rebuild, but I don’t know why anythign would be corrupted if there was no modchip to begin with.

check backlight drive ic if any passive got damaged since left joycon repair has potential ribbon cable plug-in mis-aligned when device “hot”

Nvm, you have Hekate working, so should not be backlight related.