No amps, no shorts where to start

Hi all,

Bought a switch off ebay to try and repair as a replacement for the one my son broke a while back. When I connect the voltage/amp tester I get zero reading on the amps. I have tried two different battery’s and the same result.

I have checked continuiety between the coil fuse and all capacitors and I can’t find any faults. The only issue I can think is the USB port is broke but looks good on inspection. It does however look like its been changed before so maybe not all pads are making connections I don’t know.

Would just like some pointers on where to troubleshoot this. And thanks for the awesome forum learnt so much on here.

I suggest that you start with checking all the components around the chip called M92T36

If there is a short around M92T36 test to remove the chip and check again for shorts, if the short is gone replace with a new chip.

There are more steps but you could start with this.

Thanks for the reply, all the components around the M92T36 have continuity. All looks fine but same result.

Okey then next step should be to check around components around the battery management chip “BQ241923” it would also be good if you check voltage around that chip with charger connected, maybe no voltage manage to pass from the charger it self because of a faulty charging port (as you mentioned it has been replaced before).

I checked the main fuse first and I was getting around 5v there, around the battery chip I was only picking up a voltage from one cap at 0.5v

i know at least one should bypass 5V… i think that our problem could be in that area… maybe the chip it self. I will try to get you some readings to compare with.

I have noticed the caps around the M92T36 all read under a volt too. Also the coil has no voltage, but passes the continuity test fine.

im not sure about the volt readings around the MT92T36, but i have seen Volt passes around the battery management chip before. on the other side of the board there is another chip called PI3USB, just to make sure please take some readings around the chip as well.

Same as the battery management chip under a volt. So is the battery management chip faulty then?

Could be, thats my guess or the USB C port it self.
There is a large cap above the PI3USB, what does the multimeter show in multimeter on that Cap?

Continuiuty is good but no voltage 0.03v on the cap

Then i think its somthing with the USB management chip or USB port its hard to say without taking a look at the board.

Quick update.

Looks like it is the MT92T36 I get 5.3v from the fuse then I traced that to the bottom left pin on the MT92T36 and I also get 5.3v. I then checked every other pin and there’s no voltage leaving that IC. I will get one ordered

Yeah somtimes its just to replace that chip whatever reason or without logic haha… Its a chip from hell for sure :stuck_out_tongue:

Let us know if it worked to replace the MT92T36

1 Like