No Display rx 570

Can anyone help me recover my gpu with no display after a bios flash,fans are spinning and it’s detected in device manager and gpuz,only able to use integrated graphics and motherboard hdmi no display using gpu hdmi.
Had problems with display drivers after updating driver on Adrenaline.
So tried a bios flash on techpowerup using ati flash selected the correct one for my gpu but it just bricked it.
Can anyone help I can’t afford to replace it.


There’s a few steps you can try out before possibly “destroying” more:
-check your BIOS/UEFI: is your card recognized? (it probably is since the device manager in windows shows it), is the card set as the device to use, if not, set it. Some BIOSes set the standard device automatically to the iGPU after a change. I can’t tell you where you’ll find this option in your specific bios, as it’s different for every brand.
-Some GPUs come with certain ports enabled, and certain ports disabled. A GPU BIOS flash can possibly change this default config. Check the manual for specifics. This is especially true when using multi monitor setups (as example; with a 1080ti and a DVI-D device connected, some HDMI ports will be disabled by default and you can practically change nothing about it).
^some mainboards have both graphics cards powered up, so you very well might have a picture on iGPU despite your dGPU actually being up and running.

If the above fails, get back to me.

Yes the card appears in device manager.
I have changed the initial display to pcie in motherboard bios but then the pc won’t boot using the rx 570 hdmi so it’s just like it’s bricked the fans spin and it heats up.
If I disable card in device manager and then search for hardware changes it finds the card and says its working properly but nothing changes with trying to boot up using gpu display the cpu is working fine it’s an athlon 3000g the motherboard is a gigabyte b450 I noticed on the motherboard bios it version 52 and the latest ones are 60,61 but having trouble uploading a new bios using q flash it won’t install a new bios could that be related?
I sent it to repair shop here in Ireland don’t think they even tried to repair it they certainly never opened it.
I’ll include some photos any help or ideas is gratefully welcome.
I can’t figure out how to interact with the gpu when using integrated graphics on motherboard bar just viewing it on device manager and gpuz.
So I can’t even attempt to flash a bios again because the card doesn’t appear in ati flash

I tried sending the pictures on this it wouldn’t let me

Hey update.
I bought it back to life using ati flash dos and making a bootable USB drive using rufus or something.
Booted into freedos from motherboard bios and followed instructions to force a bios flash on the rx 570 I just picked the latest one from the list on techpowerup for my model and the card came back to life.
Saved me a fortune.
Just giving you this info so you can use it as a suggestion if your ever helping anyone else