Pressing the L2 button affects the right stick on a PS4 controller

So I’m currently playing Farming Simulator 19 and the L2 button is how you reverse equipment but for some reason pressing that button causes the camera which is controlled by the right stick to move up. The controller is a CUH-ZCT2U model and isn’t even a year old as I bought it may this year it also has analog stick drift. And the right stick has absolutely no dead-zone when pushing to the right.

So the controller is even worse off now. I took it apart to just clean up everything hoping maybe it was debris bridging a connection, this is usually what I do when my controller act up.So I don’t know if it’s something I did or not but when I put it back together I attempted to turn it on to test it again, well I pressed the ps button and nothing happened, it wouldn’t turn on it didn’t even flash like it was trying to turn on. That’s when I took it back apart to see if it was all connected properly and from what I could tell it was. My next idea was to replace the ribbon cable that connects the charge port to the board well I did and still nothing then I thought ok maybe the battery is dead So I took it to my ps4 and connected it to a charger well it started pulsing orange like it normally does as if it was charging, so I left it on the charger and eventually came back to it after 15-20 minutes but when I unplugged it to attempt to turn it on it still didn’t work. I then decided to plug it back into my ps4 and hit the ps button to turn it on, it flashes blue then connects I test all the buttons, they seem to work so I hit the reset button then turned it back on, it’s been plugged in the entire time, well it turned on so this time I decided to unplug the charger and as soon as it was unplugged the controller immediately turned off. It like it’s not getting power from the battery at all nor will it charge. At this point I thought, faulty battery, so I grabbed a known Good battery that was fully charged and plugged it in and attempted to turn it on with a known Good battery and it still it did nothing. So I’m at a loss on what happened the thing that is strange is this occurred before once, I was playing and the controller just randomly cuts off and wouldn’t turn back on, the ps4 never said the battery was low but I charged it anyway and it never worked so I took it apart cleaned it and over looked everything (I’m not a expert so I don’t know what exactly to look for) anyway I went to put it together and dropped the controller in the process, I picked it up and continued to put it back together and when I finished and pressed the PS button it turned on, so I assumed that it was dirty contacts on the battery connector. Now that it’s doing it again and cleaning didn’t work I wonder was the battery connector loose and when I dropped it did it cause it to make a connection and since I took it apart today did the pressure let up causing the connection to break again? Like I said I’m not an expert in this stuff I never soldered or desoldered anything before as I don’t know how to solder yet. I don’t even know what all the parts are called so if there is an issue on the board There is normally nothing I could do other than trash it and salvage the buttons, still I’m curious on what the fault could be.

Update the L2 button doesn’t seem to be effecting the right stick anymore. I removed the battery and am using the controller with a wired connection so now I’m wondering was there a short and now that the battery side doesn’t work is the short gone? Like I said I’m not an expert but the battery connector is on the right and the charge port connects to the left of the board if viewed from underneath so is the power going through the shorted part or is it being bypassed now that the power is entering the board from a different location?

Sounds like your power control chips gone bad mate you can buy them on ebay here’s the link to one should you need it

1 Like

Well I don’t have a soldering iron nor do I know how to solder so if that is the problem I’ll have to get a new controller, at least until I get the knowledge on how to solder, I watch both TronicsFix and My mate is vince and it doesn’t seem too difficult but then again they are experienced I’m not.

Got a bit of a question keep in mind I’m not experienced with this at all, but if it is the power management chip should the controller not work as a wired controller as doesn’t that chip manage the power coming in from the ps4 as well as from the battery? The ps4 controller works fine if connected via USB. If the power management chip was faulty I would assume the controller wouldn’t work at all. When I was thinking about this I thought maybe the ps4 manage the power itself so I plugged the usb into a adaptor plugged into a outlet and it still works as I can turn it on and Bluetooth it to my phone.

Could just be a partial fault

K well I know someone who knows how to solder so I may buy the chip and get them to give it a go or I may just use it as a wired controller as I really don’t mind I’m just curious on what happened.

1 Like

Man wireless is annoying every usb I had wouldn’t stay in and when it was disconnected the ps4 doesn’t immediately recognize that the controller disconnected and it almost killed me on the long dark as my character continued to walk forwards what I did to solve this issue is to glue the charger in place from the inside out (I made the hole where the charge port sits in bigger so It all could bond. It’s a sturdy connection, so for a ugly patch it works :slight_smile:


1 Like

Well that’s a simple solution to a really annoying problem nice hack mate I love it

1 Like

Yep, still works too and the controller has been dropped a few times while I was getting used to it being wired and it is still strong, when I did that I swore it wouldn’t work at the very least I thought the glue would get inside the port preventing the pins from making a contact but it didn’t and has been working since, best of all it stays connected so the “fix” worked as intended :slight_smile:

1 Like