PS4 cannot access system storage when reinstalling software

I bought a broken PS4 guy said nothing would come on the screen had blue light of death so I put washer on the apu fixed that problem then when I booted it up it was in safe mood told me to download the latest reinstall software so I did that and now it loads 99% complete them says cannot access system storage. PLEASE HELP THANKS

Usually that’s a hard drive issue but no way for me to know for sure. Have you tried booting into safe mode and rebuilding the database?

Yes I have tried every setting booting up in safe mode. Can I take a hard drive straight out of another PS4 and put in this one or will I have to change anything else

You would have to install the system software onto the hard drive that you put in it. You can get the software right on Playstations website along with instructions.

Yes I understand what you are saying I done that with the usb and it loads up to 99% complete then said cannot access system storage I’m not sure if the internal hard drive is bad or what