Ps4 doesn't turn on, no beeps. However beeps when eject CD is pressed

Hi everyone,

I bought a broken ps4 to try to fix but I am pretty sure I was lied to…

The listing said it had a blue light and beeped when trying to boot…

However now that I have it, it doesn’t have any lights whatsoever…

Currently the situation is:

  • ps4 is connected to power grid
  • press (touch) power on button: Nothing happens
  • press (touch) eject CD button: 3 beeps

What I’ve tried already:

  • connect to different sockets and some wall sockets.
  • trying pressing long on power button
  • tried to press the top and bottom side of the case in as I found online it could be a connectivity issue and it could help.

I think (hope) it could be an issue with the power button maybe? But I read some where it could be a defective ram? However the guy that sold it to me guarantees that it was working a day before I got it… I find it weird that the ram would die in one day…

I currently have no torx security screw diver which prevents me from looking deep inside(I’ve gone some coming in the mail already). But I find it very weird that I can’t find anyone with this same issue online, I was wondering if here someone had come across this issue before.

I managed to, “fix” it.

To anyone that may run into this post in the future, in my case it was just the power button metal plate that was not getting contact with the motherboard.

I opened the case and bent it a bit more upward and it touches the motherboard no problem, not it has a blue light.