Ps4 dualshock controller L2/R2 buttons always active?

Hello,

Several months ago, my PS4 controller started acting weird when I go to play any game that uses the L2 and R2 Triggers. All games think that they are always being pressed. So I looked and looked and found the conductive file for my controller (motherboard is JDM-055). Once it came I removed the old one and replaced it with the new one ever so carefully. No Luck, both triggers “think” they are being pressed.

I could not find anything else in regards to this issue and just a couple of days ago the controller I bought to replace this one starting doing the same thing with the Triggers!!!

I think I watched just about all of the TronicsFix videos on the controllers and Steve touched briefly on one of the triggers not working and I started to get excited, but it was just dirty from the remaining flux, ugh.

I have not opened the second controller yet to see if it is the same motherboard, but if anyone has anything that could help resolve this issue, I would be most appreciated. And I won’t have to buy a new controller. (although to be honest I probably will tomorrow). But then I can fix these two and then have 4 instead of just 1 right now.

Thank you

Hello @bsmithjr7,
I often encounter this strange case, you could try to visit the link i will give you, it will direct you to the one of the discussion which has the same problem like you and ofcourse it’s already fixed. Maybe this will help.

Thank you. I will give this a try tonight and let you know if that worked. I appreciate the help!

Update, I tried to add a piece of tissue under the conductive film where it meets the board, but no luck. I left the battery plugged in and the usb cord plugged into the controller to see if the computer properties would change. They didn’t.

If I understand this correctly, with power and the computer recognizes the controller still then it should not think that any buttons are being pressed, right? For some reason it still thinks the L2/R2 buttons activated.

I am unable to upload some pics that I took (.jpg). After dragging them to the reply section I see them in the preview section and I click “reply” to post it. But, I keep getting the message: “Sorry, you can’t embed media items in a post”.

Yeah i know, but i did experience this, L2/R2 when didn’t connected (without conductive film) it sometimes does pressed itself, but when i connect it to the conductive film the L2/R2 stop pressed itself, i don’t know if all type controller like that but i did experience it sometimes. If with the tissue bump didn’t work i think you should try to replace the conductive film itself but you did say you already tried doing that so i don’t know any other way.

FYI the case where you can’t upload image or link it’s because you are a new member so the you are not unlocking it yet to prevent spamming. You need to login for 5 days strike or posting a few discussion like this, answering other problem is a way too.

Correct I did try replacing the conductive film but that was before the tissue bump. Let me give that one last try but with the new film to see if I do get different results.

That makes sense now. Thank you for explaining that. I was getting frustrated, LOL.

I will let you know how the new film with the tissue bump works out.
Thank you!