PS4 powers on after multiple presses on Power Button, then shuts down

My PS4 started having this problem recently with no reason at all. I have to press on the power button multiple times for it to start. Sometimes, replugging the cord to the wall works. Anyways, once booted, it just shuts down (hard power off) after some time automatically. Sometimes the power button on the PS4 or the PS Button on DS4 consistently fail to power the PS4 On. I have to wait for sometime then and try again. At times, it works and other times, it doesn’t.

I tried rebuilding database and initialising but the PS4 shuts down midway. I have also tried cleaning the dust both on the fan and the power supply. What could be the issue and how to fix it? From the details, any way to say if it’s the APU or the PSU or something else altogether?

I don’t know if it means something. I have found that the PS4 when it decides to switch on takes more time than usual to the power button press or PS button on DS4. And, when I tried to open the PSU to clean it, I received an electric shock on touching one of the points even though it was disconnected from the power source completely.

Good afternoon have you tried before to change a new PSU

Nope, but tried thoroughly cleaning it. PSUs where I am from are pretty expensive. So, I am looking for a way to confirm the problem area so that I don’t lose money.

Can anyone help me diagnose the issue?

ask for a borrowed power supply unit and test it…

It started working “almost” normally since yesterday. I don’t know what happened. But, I did notice that soon after plugging the cord in, I have to wait for 10seconds before pressing the power button or else it doesn’t power on. Keeping the power plug in, if I were to switch it off, and then trying to power it on, the press on power button is detected instantly. The lag happens only if I replug the cord.

that;s completely normal…

That’s a south bridge problem…