PS4 Slim Optical Drive Won't Turn On - Power Cables Issue?

Hello,

I’ve had a problem with my PS4 slim optical drive, so I disassembled it according to a guide in order to fix the aluminium plate above the disc so that it doesn’t make this horrible grinding noise. I then reassembled it and I noticed that the drive is not working at all anymore. I can power up the PS4 and everything else works just fine, but the optical drive seems powered off. There’s no reaction to disc inserts (I can’t even insert it a bit). If I click on the eject button, it just peeps 2 times and nothing else happens. I reopened it a second time in order to remove the top cover of the optical drive and then I powered on the PS4. There’s no light coming out of the laser and the parts are not moving at all.

To me, it seems to be a power issue. I checked all the white ribbon cables on the backside of the PS4 slim, and they seem to be solidly connected to the ports. The only cable that got a bit folded during the opening process is the ribbon cable that starts from the power-on button region, but it’s still not torn or anything. Anything else that I could check? The drive worked before I opened it in order to fix the grinding noise. I’m not sure what I’ve damaged so bad that it doesn’t even turn on anymore…

PS: This little thing came off during the reopening:

imgur dot com/674ktDI

Any idea where this is from on the PS4 slim?

This is how my drive looks currently with the top removed:

imgur dot com/qTBuoz5

What was the original problem you were having with the disc drive?

The original problem was a loud grinding noise every time I put in a disc. I tried to flatten the top part of the drive and now that I’ve put everything together, new problems arose.

The electronic part of the drive does seem to work now. It was all about the position of the laser block. It was very close to the center, spinning part and now that I pushed it all the way back on the rails, it accepted the disc and reads it correctly.

Unfortunately, the problem’s not solved,yet. The eject button doesn’t work. When I press it, the disc stops spinning, but the plastic mechanism doesn’t seem to react so the disc stays inside and starts spinning after a few seconds pass.

I can eject it manually with screwdriver method. but once it’s out, it doesn’t get accepted in. I can push the disc in so that it touches the two rollers on the side, but the mechanism still doesn’t respond.

Update: this plastic part seems missing (is this the culprit or are there even more plastic parts that are missing?) Does this part look the same as on the other side or is it much smaller in size?

i.imgur dot com/FZXxErr.jpg

Just noticed that that part is only present on some ps4 slim models and not on others… so maybe I’m not missing any plastic parts?

Check the large ribbon cable to make sure none of the clips were damaged because if just one was you need to replace the entire cable