PS5 controller refuses to connect to anything

I’ve tried everywhere and nobody has had an answer so far. I bought a controller before I had the ps5 and got one with the ps5. The one I got with the ps5 I packed away as a back up in case the first one broke, and a week later, my original controller died and refused to charge. Absolutely nothing charged it, no matter what I did, so I decided to try my back up. I plugged it into my ps5 and let it charge to full, then played it until it died. After it did, I plugged it back into the ps5 and had the same exact issue. The controller only gets hot when you charge it for a while and it refuses to turn on. I’ve tried plugging it into my pc, used the cable that came with it, restarted the controller, everything. For some reason it’s only those two controllers, I bought a new one out of necessity after trying to fix the first two and failing for a week and it’s worked fine for the past week I’ve had it. The new controller has only ever experienced the cable that comes with it connected to the ps5, just the same as the second broken one, and it’s still working just fine. I’m hoping somebody here has any idea what’s wrong with it, if not I’m just going to sell them as broken but I really don’t want to do that.

Im not an expert with controllers, but I can try to help to the best of my ability. I know at the very least the controllers have a fuse built into the battery, which could be causing then to not charge. I don’t think it’s possible to replace the fuse since it’s enclosed in the plastic part of the battery. Maybe if you are willing to open up one of the broken controllers and try replacing the battery that would fix it?