Resistor near battery charger chip shorted

I bought a broken switch and it isn’t turning on.
It does charge but has no sign of life; nothing is showing on the screen, nothing is turning on etc. The only thing that shows anything is the charging port, DRAM, and processor. The shield on top of it becomes a bit warm.
I tested around and the Power Delivery chip (M92T36) and its resistors seem fine. I do have to add, I basically know nothing about the mainboard of the switch itself.
The one thing I did find is that the highlighted (what I think is a) resistor is shorted. It’s near the Battery Charger chip (BQ24193)
Does anyone know what part is broken and what I should be replacing?
I’ll try to answer any questions but as I said, I’m not that knowledgeable in this field in general.
I’m sorry I couldn’t find a different way of including an image, you just have to remove the spaces in the link.
(https:// drive . google . com / file /d/1ULsWL5YpFGbfB8oADHZdjPfnT19lkgGM/view?usp=sharing)

If I remember correctly, the highlight resistor is 0 ohm resistor by design. unless you have a HAD-CPU-XX v2 board but you using v1 mapping(wrong values)

I guess that could be a thing but all of the other values match I think? Is there anything else i should Test for?

if you plug the board into a PC, do you get the USB connect sound?

Yes it does, is that good?

Likely it’s on RCM mode. Inject payload to see if it runs

I’m trying that, but my PC doesn’t recognize the device and TegraRcmGUI can’t find it as an RCM device. Is there anything I need to do? I installed the driver that it told me to but that didn’t do anything

Ok I fixed it by using a new cable, I successfully injected a payload and tried to turn it on. It didn’t do anything as far as I can tell

Which payload are you injecting, and what is the output you are getting in TegraRCMGui when you do so?

I’m injecting TegraExplorer and this is the output: RCM
Device with id C083FB060000000C0368456401101062 initialized successfully!
Uploading payload (mezzo size: 92, user size: 123124, total size: 189340, total padded size: 192512)…
Smashing the stack!
Smashed the stack with a 0x0000 byte SETUP request!
Payload successfully injected

Looks like it is a patched switch that is stuck in RCM. My guess would be an issue with the emmc, assuming it is plugged in.

1 Like

It is plugged in, is there any way to test it besides straight up replacing it?

Replacing it wont help you here, the emmc is matched to the CPU. You could connect it to the PC with an adapter and see if it can be read there.

Ok, sorry to be so dumb here but what adapter and how do I read it and what do I need to read? Or summarized; please explain this to me as if I was 10

You can get adapters that you plug the emmc into, and then can plug them into the SDCard slot on a PC. If you get the right ones, you can in theory back them up, but even if its not perfect you can at least know if it is working hard-ware wise by whether windows detects it.

I have never used these ones, but something like this:

Alright, thank you!! I’ll look into it, and just write the results here once I’m done