Selecting a Conductive Film (L2 trigger issue)

so i was just gifted a used PS4, opened it, cleaned it and applied the perfect amount of thermal paste =)
The controller i got looks almost new but the L2 button is always pressed on. By this i mean that the trigger works normally and feels entirely normal but nothing happens when i press it. Unable to go to upperCase letters when writing a message. Also when got into a game, i saw that the game records the L2 button being constantly pressed (character movement, map zooming out on its own…).

So i opened the controller, disengaged the L2 and R2 triggers and had a look at the silicone piece
and Conductive film under them, everything looks goo and clean. Now there is a very very small scratch on the film under the L2 Trigger but i may have made it myself while testing it.
The R2 works when i press the silicone piece, but not the L2.
I was investigating the issue and came upon the idea that it might be the conductive film that would be damaged somehow. I’ m willing to try to fix it but i need help selecting the right model since i’m getting incomplete/conflicting informations on the websites i’m checking.

My Controller is a CUH ZCT2U with number 4-698-771-22-F2 and it has the lightbar on the touchpad so according to consoleskins website on controller generations it’s a gen 4 or 5. (not getting exact match with their numbers)

So in the end i’m trying to find out which Conductive film to buy (considering its a conductive film issue) and hoping someone can help me.

Hi, so I found that my controller is a jdm-50 and I ordered the corresponding conductive film, which will arrive next month.

Now last week I ordered a new controller from eBay, which ended up being a fake/copy and didn’t work properly (Left stick got no diagonal) (complained to eBay and got a full refund and I’m able to keep the controller!) So I spent a few hours disassembling this fake one and noticed that it had the same conductive film than the one I ordered in replacement ! (Which will arrive next month at the earliest)

So I swapped the conductive films and sadly, it didn’t solve the issue. I tried to clean the connections on the film and the board and it did nothing. I also swapped the silicon pads from one controller to the other, the triggers themselves… And now it seems my R1 and L1 have stopped functioning as well. I don’t understand what the heck is happening, hoping it’s just a static issue that will solve itself.

Also, I watched a few bros on YouTube showing how they fixed their issues by adding tissue between the trigger and the silicone pad and another one added tinfoil between the pad and the conductive film, and another one just replace the pads. None of these tricks worked for me.

So I bit the bullet and bought a new one online at Walmart (out of stock everywhere else in QC Canada) and it seems even they have to order it from a third party… I’ll keep trying to find a fix, but I’m starting to wonder if it’s not an issue with the motherboard or if the controller is just defective.