Severence, a quick question if you have a moment

Hello! You seem very knowledgable about Switch so I figure I’d ask your advice.

My Switch of 2 year just got the blue screen but it very rarely will boot momentarily to first logo and one time fully boot!

I first noticed MAX77621 right below nand/emmc was not getting all voltages and not outputting 0.8v on the large cap nearest Tegra (like on a good board). I noticed an iffy but not shorted cap and replaced it. Now it got it’s 3.9v . Yet, still blue screen.
I then swapped that MAX77621 and fuel guage. They were taken from donor boards so their condition has to be assumed. I may even try others but wanted to ask this question below first.

I do not get 1.8v on the testpads near backlight connector, near bottom MAX77621 or above the swapped MAX77621 (near emmc).
The problem being that I’m not sure I was ever getting it consistently as I’m not perfectly sure which chip or chips make 1.8v (MAX77620?).
But in the rare time that it booted I did get 1.8v on those test pads!

If MAX77620 makes 1.8v, is it not unusual for it to go bad but very occasionally work for a little bit?
Finally, do you have links to any charts or diagrams for knowing which rail is which?
Thanks! I

GPU rail won’t come up until you clear the second boot logo so don’t worry about it, likely not the issue.

I’m not really sure which TP your reffering to, or what that TP is doing without context (maybe TMP IC?) so not really sure about that one

Swapping the fuel gauge makes sense, I am assuming you reballed it proper with stencils and solder paste etc?

afair, the console has to be prompted to boot to get your 1V8PDR, it would be pretty rare even in a fault condition for this rail to be missing as it’s seemingly tolerant… and by tolerant I mean people have described this rail as being almost a dead short to ground in some cases and still coming up. So that would make me think you have a prompt issue, so if your relying on USB for example to prompt it to boot instead use the power button flex and hit the pwr button or directly short the relevant TP to ground instead and see if 1V8 shows up again. - if you find it is, then you likely have USB or USB related circuitry issues.

That’s the one.

Just what I’ve already posted on the forum

1 Like

thank you for the reply!

Yes, I was playing the console 3 months back & it crashed & went blue screen. I ordered the tools I needed that I didnt already have, including stencils and paste. The parts I swapped over came from a donor that worked fine but had no emmc board so I assume they are good.

The testpads I am checking are J1, 3 & 6 in this photo. The MAX77621 I swapped is the one right below the J6 testpad.

The one time it did boot normally was during voltage testsing. I touched TP J4 and did not know that was connected to the power button circuitry. So I did not even know it booted normally for a moment and only then did I get 1.8v on TP J1, 3 & 6. Upon powering off it returns to blue screen and I’m yet to get 1.8v back again.
I’m testing using the housing of my modded Switch that is good. This broken Switch is not able to be modded.

I never suspected the USB circuitry so I will look into that. The port looks great but maybe I will change it anyway to be sure.
What else on USB do you think I should look at? The filters near P13 test good. M92 maybe?
Should I swap out MAX77620 or do you think it’s not kicking 1.8v for another reason?

This is crazy but I just realized something and then verified it in testing.

I suddenly realized that the times I got to the first boot logo and then the one time it fully booted was after I turned my air conditioner on for the first time, had the broken Switch in the room with the air conditioner and then tested it in another, warmer room. It dawned on me suddenly and so I tried to repeat the process and it worked.

If I place the Switch in that cold room for 5 minutes and then try to boot it, it will blue screen once or twice but then boot normaly. Repeatable, not a random fluke. I was able to do this a few times and I get nothing if I test after it warms up.

But I think this makes any IC or transistor a possibility, right? I’ve heard of heat temporarily fixing a chip but cold temp is a new one for me. So it’s likely the change from cold to warm that’s temporarily fixing the issue at a solder or internal transistor level but how to isolate that? If it works from cold to warm shouldn’t it work with warm air so that I can isolate the components causing it?

Could be ram or soc too. In my case i test by placing switch on table. I place pressure on center screen n hold while pulling up on each side slightly(console was curve already) then power on device. It will boot. If i dont do this i get blue screen. I can place pressure on ram chip n turn on n it will boot too. My case was solve with reball of top ram chip

1 Like

Thank you for the reply!

I tried putting pressure on it in that exact way when it happed and a few times today. No change.
I’m now in a scenario where just heating up the board with a blow dryer a little bit (not going crazy) will allow pretty constant boots and going from a cold room to warm room will allow it to boot every few tries for a bit. Yet the pressure test fails so I don’t know if it’s the main chip, ram or another ic?

Nothing is obviously shorted. All inductors around MAX77620 have what appears to be good resistance based on charts and compared to my good one.

I’m in Chicago so I’m sure someone could rework the main chip or ram for me but I’d rather figure out if it’s anything else first.

I can’t edit posts so sorry for replying so much but I also notice that turns on by itself lately. A few times I got it to boot normally and when turning off it sometimes shuts down and a anywhere from 2 seconds to a minute later it will turn on to the blue screen.

Yeah, based on the symptoms this is most likely going to relate to chip or joint issues, so could be any of three things, SoC, Ram or their connection to the board

1 Like

Thank you again for the help. I think i will mess with it a bit more but if i get to the point of the tegra soc i will just back off for a while and wait until i can find someone near Chicago or until i am better at this sort of thing. Thanks!