Shorted caps under DRAM and Tegra

Hi! A few weeks ago i came back to home and found that switch was not turning on. Tried to connect into dock, directly into charger, hard & soft reset but nothing worked.

Now after inspecting with a DMM in diode mode i’ve stumbled upon lots of what seems to be shorted caps. I know some of tiniest form factor caps can have very low resistance to ground, but there’s a lot of them, in addition to a bigger ones. They’re placed just under Tegra and DRAM.

I’ve also checked the rest of chips that common fails (Pi3USB, M92T36…), no shorts at all and voltages were OK.

USB C draws about 0.46 amps.

In addition, some voltages were measured through test pads.

Any thoughts?

These are my results. Yellow blocks are shorted caps.


It’s normal for these caps to be low resistance to ground, this is likely not your issue. If you provide resistance readings instead of diode i can confirm.

The size of the capacitors play no factor in how high or low a particular voltage rail measures (on the caps) relative to ground… atleast not in any meaningful way. A capacitor measured out of circuit will measure completely open or very close to it (OL)

Is it unpatched? if so you may load up hekate and check the console info stuff and post pics :slight_smile:

Hi, thanks for reply,

I see your point about caps, thanks for the insight. When i get back home i’ll try to measure resistance :slight_smile:

My switch is unpatched. I tried the method you mentioned with RCM jig/Tegra RCMGUI but switch is not even recognized (cable is fine, tested with another device).

Hmm then it seems to point towards a bad USB connectot or possibly P13 IC, you might check continuity from usb c breakout to filters above P13