Shortening around MAX77620 causes blue screen?

A friend of mine gave me his son’s totally abused switch.

First inspection:

  • Digitizer totally scratched
  • LCD broken, no picture, backlight is on
  • USB port looks OK inside, but the shield is bent
  • Switch charges with 0,48A, no fast charging
  • Joy Con flexcables are ripped off on both sides inside the switch
  • No visible water damage :slight_smile:

What I’ve done so far:

  • New digitizer installed
  • New LCD installed, but it is broken in one edge due to bad packaging of the seller grr
  • Replaced the scratched/deformed housing
  • Bought new USB connectors and joy con sliders, did’t mount them, yet

When I turn the switch on I get a blue screen. Because of the damaged replacement LCD the upper 2cm are black.
I have measured the capacitors around the bigger chips, all on the top pcb side look OK, on the bottom side some around the MAX77620 are shortened, and therefore also some below the main CPU.

I have done some notes of what I measured till now (mainboard scan taken from switchbrew):
[Image links removed because the forum told me so…]

USB current readings:

  • OFF, no battery, no LCD connected = 0,25A
  • ON, with battery, no LCD connected = 0,46A
  • ON, with battery and LCD connected = 0,48A

Does anyone have seen this kind of fault already? Any hint what I could test next?

I would like to remove the suspicious ICs one after the other, but unfortunately I still lack the experience in hot air soldering BGA chips. I would have to practice on other junk boards first.

I couldn’t find an IC that gets unusually warm. I think there’s gonna be a protective circuit going into action. There is the trick of simply connecting a laboratory power supply to the path that is short-circuited. This method works surprisingly often, but the possible effects are:

  • The defective IC becomes warm or explodes, and can then be replaced in a targeted manner.
  • The short circuit disappears, further troubleshooting is more difficult.
  • A track burns away, within multilayer boards deadly.
  • Uninvolved components break down. Voltage regulators, for example, do not like it when voltage is applied to the output that is higher than the input voltage.

Available tools:

  • Soldering iron and SMD experience
  • multimeter
  • oscilloscope
  • Hot air station without BGA experience
  • Various laboratory power supplies


Hey there,
the caps directly around the MAX77620 on the bottom side shouldn’t be related to the main SoC. To my understanding the bottom MAX77620 should supply a 4 V rail. There’s a test point (round golden pad) right next to one of the IC’s corners. If the voltage there reads 4 V at least the output of the MAX77620 should be ok. At least that’s my understanding, please everybody correct me if I’m wrong.
I wouldn’t connect a lab bench supply to the switch’s internals, mostly because there are some conponents in there which only have very little tolerances against over voltages. So unless you really exactly know what voltage has to go where I would never do this.
Concerning the lack fast charging: Does your USB meter support the higher voltage modes of the USB pd specification? Many do not, hence fast charging does not happen due to the meter, not because of a defective device.
A blue screen might also be a software problem. It’s the switch’s way of telling you that something with the kernel went wrong. But, I have also seen it when the PCB was just dirty. Have you tried entering recovery mode and resetting the switch to factory settings? Does it even boot into recovery mode (not RCM!)?
If there’s a short in one cap around the max77620, I’d usually suggest simply replacing it, but I don’t know any place to get that IC, except for a donor switch. Maybe someone else knows a source here.

I would:

  • Check if the 4 Volts on the test point of the max77620 are there
  • Check if the USB meter supports fast charging
  • Check if recovery mode is available and factory settings can be restored

Hello, thanks for your help.

Around the Max77620 there are some testpads, I will take the board out tomorrow and measure the voltages there.

For the charging test I use a standard Anker 5V 20W 5 port power supply, a chinese V/A meter (two line LED 7 segment design) and an Anker USB C Cable. In the videos I have seen people on Youtube using standard powerbanks for the test, so I assumed that it should work. With my own working Switch, fully loaded I get about 0,7A charging. I will discharge it to compare the result.

With the bench supply I usually choose a save voltage. Most signals are >=1,6V so 0,5V can be used for the first shot to see what parts get warm. But it is my last shot if nothing else gives a result.

Recovery mode is not acessable. I can turn off the console by pressing the power button for >12s, but pressing volume +&- while turning the switch on does just show up the blue screen.
Because of the short-circuit over the capacitors (shown in the fotos below) it shoud be a hardware problem.

Adding fotos and Links does still not work :frowning:
Sorry for the work around, but I think especially the measurement results may help a lot!
“pastebin /uX7C5Dxq”


Hey there,
the Switch usually fast charges with 15 V, so a 5 V supply will most likely not be able to supply the Switch for fast charging. There are power banks which do support all USB pd standard voltages (5 - 20 V).
Have you tried if the Switch goes into RCM mode (not recovery)? If that works the hardware might be ok…
And yes, links only work if you’ve stuck around the forum for a while. I guess it’s to prevent spammers. I peeked into your pastebin, but the photos are so unbelievably small that I can’t possibly see anything on them, sorry.

Sorry the foto service has reduced the resolution. Reuploaded “pastebin /nDTa85at”.
I came home very late today, I’m too tired to disassemble the switch for more measurements at the moment. But here are some answers:

I thought there would be different modes for charging. Max 500mA for standard USB, max. 2A for classic 5V USB power supplies, and the new increased voltage modes.
I have now connected my working Switch to my 5V Anker supply, it takes 1,44A in stand by mode (not switched off).
I connected my working Switch power supply to the defective switch, I still get the blue screen. At the moment I don’t have any solution to connect my multimeter into the USB C connection. Because of the continuity check across the capacitors I still think it must be a hardware defect.

I have also tried to enter the RCM mode (it’s a first generation model, so it should normally work), but I still get the blue screen. By the way, I know for sure nobody tried to run homebrew on this switch, so it should not be a firmware/software problem.


P.S. as soon as I can include fotos I will add them directly for reference.

Hey there,
I looked at the measurements you’ve done. Did you check if your fuse has continuity? I’m not sure if I’m understanding the arrows correctly, but one Side of the fuse says 4,8 V, the other 0,4 V. That’d mean your fuse is blown.
Did you measure Test pad 1 in cluster F? What does it say?

The Fuse is OK, I have marked it with a green border. The switch has power; takes ~0,25A if I have the LCD and Battery disconnected; ~0,48A with LCD and Battery connected.

The 0,4V are ment to go to testpad 4 in section K - measured as DC voltage. Switchbrew sais:
Pad # Name Type Levels Continuity Frequency
4 USB-PWR-WAVE? Square wave 0V-3.3V^ A-9, A-10? ~11 Hz

In section F I didn’t do any measurements, yet. I need to disassemble the switch again to get access to the testpads. (I don’t remember correclty, maybe I measured the pads but didn’t get plausible results).

The child who abused the switch has had problems with the HDMI output month before he crashed the Switch. One time it worked, the next time it didn’t work, then it worked again. That sound like a USB C Port problem. But I can’t see any bent pins or feel any loose parts on the connector. Maybe he damaged the dock instead of the switch USB C port.

I have searched the web for people who have broken their LC-Displays but I could only find fotos of broken digitizer. It seems to be difficult to damage the LCD? That makes me feel that the child did a very stong hit onto the screen. This hit coud result in bending of the mainboard.
I know that multilayer ceramic capacitors are very sensitive if the PCB gets bent. They crack and go short-circuit (" Ceramic Capacitor Cracking").


I measured the testpoints as follows.
Only the mainboard connected to my 5V power supply, no other components like battery, LCD, Digitizer, …

Section F
1: 4,25V
2: 1,365
3: 1,82
4: 0
5: 1,1
6: 0,3mV
7: 0
8: 186mV
9: 0
10: 170mV
11 0
12: 39mV
13: 1,81V
14: 1mV

All readings from that PCB side: “pastebin /Bz6ALBLx”