Shorting capacitors?

Hey Guys! I am trying to fix a Nintendo Switch that had a missing m92T36 chip and a missing capacitor. I have replaced both of them, but unfortunately, I still got some shorts. First a little explanation. When the M92T36 chip together with the capacitor was missing, the switch would get stuck on the Nintendo switch logo. After replacing both of them, the switch doesn’t turn on properly anymore. The backlight is working, but it keeps being stuck at a black screen, meaning it probably got even worse. I have already tried hard resetting, but unfortunately, that does not work. The capacitors that are now shorted are depicted in the following figures. Does anyone have any idea how to solve the issue?

Kind regards,

PS, the pictures are taken from the internet, as I do not have a high-resolution camera.

switchshorted1 switchshorted2

Some addition: It turns out that the black screen is due to the fact that the ribbon cable connector is damaged. I am back to the original fault which is that the switch gets stuck at the switch boot logo. Does anyone have other suggestions? I thus tried to replace the M92T36 chip, but that unfortunately didn’t solve the issue.
Thanks in advance!

Okey so it turns out that those parts should have continuity as I tested it with another nintendo switch, thus that is not the issue. Does anyone know a solution? It is thus stuck on the switch logo and I tried replacing the M92T36 and the BQ24193 chip already. I am totally out of options.

I can confirm those components do have continuity, I just pulled out a working board and checked as well. They aren’t capacitors. (Probably diodes)

When the Nintendo Switch boots to the logo, it starts doing a POST check like a PC. It checks to see if it can communicate with the battery properly. In the past when I’ve had this issue it has been BQ24193 or the Fuel Gauge IC (which I cannot find replacement parts for anywhere).

Something else you can try is boot into RCM mode and inject a payload to check the battery status, if it is reporting the battery status correctly then you know it is communicating there properly, in my case where it should be showing hex values it showed jargon.

1 Like