Stack with the Nintendo Switch logo (second logo)

Hello everyone.
I am trying to fix a console that gets stuck with the Nintendo Switch logo.

I was able to boot Linux, so I checked and found that the WiFI adapter was not detected, so I pulled the WiFi chip (BCM4356) from the donor board and replaced it TWICE.

However, it does not improve at all.

I’m thinking that power may not be being supplied, how to examine do not know.

Does anyone know how to investigate, how to solve it, and what to look for next?

Can you describe your process to replace the wifi chip? Did you fully reball? This IC is has a dense ball grid and it’s super easy to scoof-up with refitting. Voice of experience here!

Sheriff

Thank you for your reply.
Reballing work was done using a stencil and solder paste.

And I’m sorry, I solved it.

This console to taken apart by the previous owner.

I heard that the same symptom appears when the two capacitors next to the SoC break.
スクリーンショット 2021-02-28 034751

The capacitor was fine, but in the process I found the peeling of a land portion under the SoC shield cover. The SoC shield cover got in the way and I didn’t notice it at first.

When I finally repaired the disconnection, it started up safely.

I think it was peeled off when the previous owner removed the SoC shield cover. That is certainly difficult.

Thank you for your help.

I knew i was remembering wrong :slight_smile:


Glad you solved your problem and thanks for confirming :+1:

I’m sorry if I caused a misunderstanding by my poor english.
Your idea will be correct.

this is SX Core(MOD chip) Questions and answer.

Therefore, it can be seen that the rail near this capacitor is often related to WiFi.

Nope this isn’t your misunderstanding, your english is excellent, it’s mine, i didn’t pay close enough attention the to the lines in question :slight_smile: