Stuck at Nintendo Switch logo (the 2nd logo) BQ and M92 are okay


i bought a Switch which stucks at the Nintendo Switch Boot logo. I replaced the BQ IC as someone in the Forum mentioned this could be a cause of the boot logo stuck. As this did not help i also tried to desolder the M92 (the Switch should boot without the M92 into an error code). But even without the chip the Switch doesn’t boot. So i put the M92 back on. I also checked charging current with 5V and 15V both are working without any problem (0,8A @ 15V and 1,45A @ 5V. Is there any other part that can cause a 2nd boot logo stuck?

Kind Regards,

Unfortunately the Switch is patches so i cannot Diagnose it with Hektate. But i can connect to my PC via RCM. I also checkte the nand with a unpached switch and it got initialized. It would realy help me to know which components prevent a switch from booting and Also how. For example i know, that a defective fuel gauge would just Show a black screen.

TRY work on the wifi ic

Couldn’t it be coming from the SOC as well ? I don’t remember where i saw that this could cause a Switch to get stuck on the second logo. You definitely can launch Hekate on a patched Switch, just remove EMMC and you should be good to go, that’s how i do it, just to troubleshoot. You can still replace the EMMC on the fly to read the info about it.

Thank you for your answers. When i bought the Switch the seller sais it had a water damage. However only a little corrosion Was around the the bq Chip. I dont think the wifi IC had any damage because of this so, this will be my läßt try. Today is found out that the Max IC below the emmc did not had the 0,8v Rail when the switch is stuck on the Boot screen. So i wanted to reflow the IC but exidential removesd. Do you have any advices for reaoldering it?
I also tried to boot Hektate before which didn’t work. But im 99% you can’t Boot Hekate on a patches Switch :confused:

If you remove emmc, you should be able to, as the Tegra will run in RCM mode when not finding emmc. You are asking how to resolder the SD or the max ic ? For the SD, when I did it I was heating up from the backside of the board, maybe you could try the same for the Max IC? What you can do to avoid that is using aluminium tape, I have some left from my house construction, we used those tapes to seal the outer isolation joint

Yes of course, you can enter rcm when removing the emmc, but you cant inject Payload.
Iwas asking for the max77621. I heated it up from the back, but it didn’t came Off. After this i tried to boot but the switch didn’t Do anything. Also i doesn’t Boot to rcm anymore. So i heated it up from the Front and removeed the Max77621 as i read it should be able to boot to rcm without it. But it still doing nothing. There is also no voltage at the max77621 under the tegra.

From my side i don’t feel i have enough experience to help you more, i never worked the Max77621 before, never had to so far. I just know that once i entered such similar situation, and it turned out that i shorted 2 caps without paying attention with my iron and with the level of zoom i was working with the microscope, i couldn’t notice at first. Since in the Max area you are working caps are even closer, could it be a lead ? Are you sure you haven’t knocked something at the back ?

Hey, thank you for your reply. I’m sure i didn’t knocked something. I also checked with the microscope. Maybe the board got to hot for to long. But in my option i was pretty carfull. Maybe the solder at the tegra started to melt and it doesn’t have a connection now. But again i don’t think it was that hot. Would be interessting do know what causes the tegra to wake up or how He wakes up the Max ics as i donot get Power at any rails. I even can’t enter rcm.