Stuck on joycon screen

Hi guys, I have a switch that is stuck on the joycon screen:
After connecting the joycons nothing happens, it stays on that screen.

  • I replaced the M9: the current draws are fine (0.4A and then 1.7A when ON)
  • The joycon rails are fine.
  • It goes on recovery mode, I tried to reinitialize the console but it boots again on that screen.

Any ideas? Thanks!

Edit: Of course in Maintenance Mode joycons are not working.

maybe just before the BSOD state.

Check the caps to the left of the SoC around the middle are intact.

If that’s not the issue then it’s possible the connectors or diodes near them or on the opposing side of the board have failed or your not getting continuity somewhere, can you provide phots of the board and I’ll highlight them if neccessary… though i think @Calvin has already created a diagram for these.

You mean these two? Or under the plate?

Yes, 1 pin on the sd connector is missing, but it seems having the right value on the correspondent test pad.

Yeah, I could be wrong but i seem to remember a lot of people were somehow knocking one or both these capacitors off during SX modchip installs and it caused the same symptoms your seeing… though this is from memory only, it might have been at the second bootscreen… i haven’t duplicated this.

It might be your having similar issues to Calvin over on this topic, might be worth first disconnecting battery and power and checking you have continuity at the various points highlighted in my “diagram”. If that’s all good then check the various voltages detailed in Calvins working voltage spreadsheet and ensurig they’re all present… if not report back and I’ll try and help you figure out why.

Thanks for the tips man.

By comparing measurements, I just found this pin grounded, and some points have higher values in diode mode. (I just marked some in the image below)



I just ony inspected the R joycon, I’ll check the L later.
Any idea on what is causing that short? Thanks as always.

I haven’t fully traced this out yet, but if your green highlights represent the short to ground then you could try pulling the highlighted IC and see if the short clears in the meantime.

I removed the IC and the short is still there.

Interesting thing:

On the opposite side of the left joycon connector, there’s an identical short on the respective components.

Severance is right. This is a common problem with these two components you’ve marked. Easily damaged.

Removed both IC, short is still there.
I have to figure out where the ICs are connected.

Are you referring to the 2 caps near the SoC?

remove the following, and see if your short clears

The mistery deepens. :sweat_smile:

All this trace is shorted:

Ah, I’ll have a think

Update image, I didn’t mark this other shorted pin:

I tried to find other shorts around but no luck.
Under the EMMC I got strange values compared to another board I have:

Do you have some other schematic so i can compare? Thanks.
I’ll keep digging.

Sorry still haven’t got round to identifying your fault, i’ll check a bit later on when i get a minute.

The IC’s you’ve highlighted next to the WIFI IC… I’ve never had a consistent reading on these components, in and out of circuit from one board to the next, i initially thought they were diodes but it’s (and i’m probably wrong here as i haven’t got round to looking into them) possible they’re LDO’s - perhaps the WIF IC datasheet would shed some light on this, i haven’t checked it yet (if ones avaliable). My boards which i was testing the said components worked fine and exhibited no issues despite the reading differences between multiple other boards.

So i wouldn’t put to much weight behind these being a potential issue.