Switch Battery not fast charging (it was 20 min ago)

I’m doing a repair of a Nintendo Switch, had to change LCD, Touch screen, and battery. Also did repair of a speaker by soldering the wire back (first time using solder iron, it wasn’t great)

So I put the new battery in, and it was fast charging, but I got no screen, the touch screen was working cause I could hear sounds when clicking the screen.

Then I removed the battery and tried to reconnect the LCD ribbon, I guess I probably didn’t place it right.

When I had everything in its place, I try to turn on the switch and nothing happens. Tried to see if it was fast charging and nothing. Checked for shorts, nothing.

It stays at 0.41A, and I can’t turn on the switch like I did before (I don’t really know how it turned on last time, because I had no image, it was kind of an accident)

I tested the new battery on another switch and it’s working. So the question is why did it work the first time on the broken switch, and soon after not anymore?

Is there something I could do? Bought all this tools and lcd, touch, battery, it was going so well :frowning:

Update: I used some contact cleaner in the USB C and the battery connector and it’s working again! Bad news is I still don’t have image.
Could this ribbon cable be the cause?
I’m a new member so I can’t post links or images, this is imgur /jrvSpeA
Sorry for all the trouble

Fixed. The flex cable was the wrong way.