Switch Charger charges one way unless turned on. Anyone seen this?

Hello, I have an issue that is driving my mad.

When off:

  • Charger charges 1 way and not the other (randomly it will).

When on

  • Charges both ways no issue.

Changed port and M9 chip. Seeing how its intermittent I was hoping someone has seen this. I am leaning to the PUSB but I dont want to start changing a billion things if someone can shed some light.


Did you check the plug of the charger?
What are your diode mode values for cc1 and cc2? (Unplugged battery/no charger/red probe on ground)

460 on cc1 and 470 on cc2

Solved it, changed the p13. I assume it was detecting when it wanted to. Was really weird, maybe it got power when on and detected the plug but in a off state was not detecting the reverse orientation.

Interesting one.
I wouldn t assumed that the cc lines, which tells the orientation of the plug, have something to do with the additional signal lines, which go to the pi3…

Maybe I should try to clear my statement a little more. With my USB-C tester, it would not turn on to detect anything. Probably should not have stated charging. My mistake lol. Charger detect would run through the “pi3”?

Vbus and the cc lines (charger detection) are going to m92t36. And the additional signals tx1+,tx1-,rx1+, rx1-, sbu1 and the second set are going to pi3 (Pericom named this ic ‘pi3usb30532’ :wink: ).

Changed port > No detect on 1 side (Battery disconnected) => Replaced M9 => no change. Installed to case (Battery connected) => Chargers both ways when on and displays on dock. When battery unplugged only detects on 1 side. Changes P13 => Detects both sides with battery disconnected and works as it should. I first though maybe a bad joint under port but all connections seem to work when powered on.

I am checking out the datasheet and see what you mean regarding the CC and VBUS. So what I did should not have solved my issue. I do have a pro scope and pro equipment and a massive amount of soldering skill. I did check for bad joints. Maybe something got joy from the heat? I prey this is not CPU related…