Switch display goes black after the Nintendo logo

I will check if I can find any good guide for it. Do you have any recommendation how to do it? Do I need some special tool for it? I have never done this before.

See if you can handle the two tutorials. See what you do when you launch hekate_ctcaer_5.1.1
Also check if your console is unpatched and even if it is not, telling me if it goes in rcm mode and if it lets you launch hekate. Hope you can do it

How to Make an RCM JIG From Aluminum Foil

Is my Switch Jailbreakable? RCM + Injecting Payload Tutorial

Thanks :wink: I have a 3D printer so no problem to make a jig :slight_smile: I will try and come back to you.

I have tried now. For me with RCM jig inserted PC is always recognizing it as Nintendo switch. Tegrarcmgui remains black shows no RCm device. It is unpatched I have checked.

Finally it worked out. I could succesfully inject the hekate payload but still nothing on the screen…

I think I will give it up with this one…

Ok I think the problem is from eMMC or Tegra SoC or possibly corrupt nand. I will try to make a reflow at eMMC and maybe even at Tegra SoC. You have nothing to lose. If you know how to do it and you have what it tries…

Also try to change BQ24193. And he can sometimes gives the black screen…:thinking:
Personally I did not meet this but I heard from others who suffered.

Maybe I will try this. This is the only chip I did not replaced yet… By the way now, because I have already injected hekate payload are there a way back to the original firmware?

Press the power button for 10 seconds. This is all. And no jig. :smile:

1 Like

BQ24193 change did not helped.

this is not good…