Switch dock/charging problems

Hey guys,

My problem is with my switch that they don’t charge fast. If I tried the original adapter from nintendo the switch won’t charge, but if I use a sasmung adapter with a pro controller cable it will charge (4.97V and 1.47Amps). I have tried to use the docking station but it will blinking fast green and not charge the switch or make a picture on my TV. Is it a faulty charge ic ? And i cant use any usb devide on my switch.

Best regards

this could be caused by IC PI3USB… i would start checking that one…

Does the dock starts blinking during power on or only if the Switch is inserted?
Does the charging problem apears on both ways you could plug the usb-c plug in?

Normaly the Switch communicats with its power adapter to enable fast charging. If the CC line is shorted the Switch won t charge or connect to the dock.

I would check the usb-c port for bent or missing pins and the pins for similar values.

The dock is fine i have tried it with 2 docs same on both, starting blinking after insert the switch. I have checked the video settings for the tv there are only 480p and 720p more not. My other 2 switch function very well with the docs. If I tried to charge with the original Big N ac adapter than its only charge starting the charging at 0.04A at 15V and than 0.00.

How I said if i tried to insert a stick, controller or anythibg else it will not function.

How I will check the PI3USB ?

So the problem is a Switch related problem.

Pleaes check the usb-c port for bent pins. And please check if you get the same charging if you plug the usb cable one way and the other way around.

From my view the PI3USB doesn t matter at this point. A defect here may causes no signal output to the tv. But in your case, you not even have a propper usb-c connection to send any signals.
If you want to check anyway, look here: /t/no-dock-signal-dock-is-good/2184

1 Like

I have checked in the 2 ways and in this case it was the same error. The fuse is okay. I will check later the other thinks . I will order a usb typ c plug breakout board but i cant find in germany anywhere it :frowning:

I have checked some capacitors of m92t36, bq24193 and p13usb. They are all good the filter are good too i hsve checked the fuse that is fine. I dont know what is wrong :frowning:

I have seen one case from my repair last week after replacing the M92T36 ic, the switch wont take original charger but any aftermarket PD charger draws 15v0.6A no issue. After replacing M92T again with another new batch, original charger works normal.

Most time I check all pins diode value from typeC port first(I use type-c test board makes pins/pads test easier).
then make sure 2 rail/hidden pads from type-C, B2,B3,B5,B11,B12 pads have continuity to the related filters on top P3IUSB ic

Okay i have ordered the test board i muss waiting. The m92t36 chip i have ordered too and i need to wait for it but the capacitor on all chips are fine ?

A shorted capacitor is only one possible failure. Loose connection, not switching ciruits,… are also failures, which doesn t have to appear as a short, what could be detected easily.

I would check in diode mode for correct (similar) values. Unplug the battery, put your multimeter on diode mode, red probe on ground and with the black probe check the pins/pads. Start with the visible row of pins at the usb-c. In your case I would check the CC1 and CC2 lines. The both testpads (.507) are above the VBUS (.510) testpad on the picture .

I have checked anything all was good. I have replaced the M92T36 chip with a new one and anything works :slight_smile: it was a faulty M92T36


Thanks friend, solved my problem!! I had already changed the connector and the P13, when changing the M92, it decided
Mine didn’t load in the original loader and didn’t give an image in the dock either