Switch does not start - black screen - Battery voltage okay - RCM found on PC

Hello all,
I just got a used Switch from my parents and it does not start. The screen is black and I cannot get even a fan spin. I looked at the following things:

  • The RCM tool sees the switch.
  • Battery and charging voltage is correct.
  • We tried some hotkeys, like recovery mode. But we could not get into it. In any case the screen stays black.
    What things can I try next? What am I overseeing?
    Greetings yall :heart:

If RCM tool sees the switch, inject a payload, like hekate, if it’s unpatched, it should show sonmething on screen. The fan won’t spin on boot, only when hot.

Thanks for the fast answer.
I tried the hekate. Nothing happens and it seems that it’s patched.

What code from the TegraRCMGUI output 0x000*** ?

Hello all,
I tried injecting a hekate. The tool recognized a devied ID and could successfully inject the payload.

Also it seems like that my switch is patched (ismyswitchpatched dot com). It says possible firmware version out of the box: 2.3.0

What should I try next?

Thanks and lovely greetings,

If it is patched, and you are in rcm mode, it most likely means something is wrong with the emmc. I just got one in today, and there is no clock coming from the SoC to the Emmc, so I’m guessing dead SoC. In your case, you would neet to check your emmc in a hacked console, to see if it is in good condition, or find a way to check why the SoC is not reading your Emmc (that’s why it’s in rcm mode).

I don’t know of any better way than to check your emmc on a hacked console, sorry. That’s how I check the emmc for v1 switches. If the emmc is good, then its something on board, like a bad connector on the emmc (I have gotten plenty with corrosion on the connectors).