Switch drawing .41A but won’t boot

Hey all, I’m new here but been following for about a month now. I’m having an issue with an Erista switch board: HAC-CPU-01 PWB/AU/CHN. I have checked for shorts around the M92, BQ, P13, both MAX 7762, 17050 and found none. I checked the leftmost pins on the battery connector-both are reading 4.1V. The main thing that sticks out is pin 8 and 11 on M92 IC. I have changed the M92 IC 3x and each time I have had the same readings as shown in my photos. Attached are a few pictures I took and posted my readings on. Any help would be appreciated

Also to note: I have tried connecting it to my PC to see if it was stuck in autoRCM but it was not, I also tried removing the eMMC to see if that was causing a short/not being detected in AutoRCM.


Hey man, it’s been a long time but basically I’m in the same situation as yours. Did you ever find a solution?

Have you tried if you aren’t in RCM ?
The first person did, but what about you ? That was my issue, connect the console to a computer, run tegrarcm GUI and you will have the answer.

No it’s not going in rcm mode. When I turn it on with my power supply it stays at 0.26A~ without doing nothing, when I plug the charger it stays at 0.45A and nothing comes to life :frowning:
(I already changed the m92 and bq24 IC)

You may want to swap out the fuel cell. That’s another common failure mode that will block boot.


Can you explain me what and where it is and how to check if it’s broken? I’m only familiar with iPhones unfortunately

Fuel gauge. I apologise. You’re looking for the Max 17050 behind the battery connector on the other side of the board.

My readings there