Switch Draws 0 amps, won't charge, boots happily

I’ve got a switch that I installed a Picofly in. It was my first time doing this kind of work and I did an acceptable job.

Today I turned this switch on and it wouldn’t boot the mod chip. I took it apart and found that both the ground and 3.3v wires had gone off their solder points on the main board. These points are around the m92 chip.

I spent a little time getting them soldered back down. I had trouble with the 3.3v point and ended up switching from 30 AGW silicon insulated wire to 40 AGW magnet wire. I managed to get this soldered in and wired up.

I was able to get the ground wire in but I bridged the ground side of the cap next to it. I figure this shouldn’t matter though as they both go to ground.

Once things were in place I powered it up and it booted to hekate. I sealed it up and considered it done. But when I plugged it into the dock I got a blinking green light. I tested the dock with a known good switch and it worked fine. I then plugged the problematic switch into an OEM power plugged directly into the wall and did not see a charging icon. I got my USB power tester and it shows 5v 0amps. It looks like it isn’t charging at all.

I went back to the bench and opened it up again. I tested for shorts around the m92 chip and everything seems fine. I also checked the fuse and it took seems fine.

So I’ve got a switch that powers on but won’t charge. Fortunately it has a full battery so I can do some testing.

Any thoughts on where to start?

Just tested BQ for shorts and it seems fine.

First off remove that bridge if it wasn’t there before it doesn’t belong there and is likely causing your problem, always look at the obvious then go from there.

Yeah, that’s definitely the place to start.