Switch game card reader not working even after replacement

Hey there,

I recently changed my Switch’s game card reader that wouldn’t read games (bought it like that because I knew it was an easy repair), displaying the infamous message “The game card could not be read”. Usual methods wouldn’t work so I had to buy a new one. Problem is, even after installing the new game card reader, the console doesn’t seem to be able to read any game cards. I tried with a brand new game never inserted before.

I tried resetting my console as well but it didn’t do the trick unfortunately. Any idea why the card reader would fail ?

Switch is V1. I tried with no result :

  • Resetting the console
  • Unplugging the battery then holding the power button for 30s
  • Cleaning the card reader with compressed air
  • Cleaning the game card
  • Plugging in a jack headphone (some people said it worked ?)

Can u read and test the card reader pins ? Let me know the diode measure?

Hello there, I got exactly the same problem with a V1 Switch. Brand new game card reader doesn’t make any difference.

@Fallcon Have you managed to solve the issue?
@rickykei May I kindly ask you to precise what measurements do you need?