Switch Lite backlight for Nintendo logo then off

I have a weird one I hope someone has seen before. A tale of two Lites and my learning the hard way that the proper process is to connect/disconnect the battery UNDER the ribbon cable to the daughter board versus pulling the ribbon cable out of connector with battery still connected…

Summary of problem (details below): Lite boots up, backlight comes on for Nintendo logo but not for switch logo - dark screen from there on. But it is booted, buttons and sounds are working. This is after replacing the TPS61162 backlight chip with new pre-balled unit.

First lite worked fine. Second needed a new joystick and a new touch screen (scratched up bad) but otherwise worked fine. Made the swap of touch and joystick, put it back together, no display. Troubleshot, found it was indeed booting by watching charge current and then trying buttons - could hear the “three pushes” sounds followed by the opening sound. but no backlight. Pulled board and inspected, opened a working Lite to compare readings. Readings around 61162 backlight chip were different, looked closer and found chip had rough edge so pulled it and ordered from Mouser. Meantime i pulled the rest of the components and compared them to a Switch donor board, found different readings on the Schottky diode and inductor so moved them from donor board to first lite, thought about moving the chip but new ones were one day out (and I don’t enjoy reballing something that small).

Put the second lite back together and it now had same issue!

Did a bunch of research, found I should not have been disconnecting the daughter board ribbon cable with battery connected - I’d seen videos of folks struggling to unplug battery with ribbon on and thought “gee, why don’t they just pull the ribbon like I do” - now i know!

Not sure if the ribbon or my probing blew the second lite but opened it up and found the same readings, tried to measure voltage and slipped with probe, magic smoke escaped from the inductor. so pulled the TPS61162, inductor, and Schottky diode and replaced passives with parts from a Switch donor board.

Chips came from Mouser, replaced them both. Backlight comes on for the Nintendo logo, and once in a while for the switch logo and home screen but most of the time not. Switch is operational, i can hear button activity and even (using another switch to count the moves) navigated to the systems menu, brightness menu, and heard the brightness slider clicking up and down - all with no effect.

When backlight is on for logo, pin 1A (ISET) of TPS is 1.2v. When it goes out it drops to near 0 and stays there. I haven’t found easy access to the EN (1C) so don’t know what it is doing. Voltage in is 4.2V but the Vout at junction of Schottky and filter cap is also 4.2V. But obviously jumps up when booting as lights come on for Nintendo logo…

I am continuing to debug but wanted to get all this up on the forum (GREAT RESOURCE by the way) and see if anyone else has ever seen anything like this.
Any help appreciated, thanks in advance!
Dave