Switch Lite charging, but not power

I bought Nintendo Switch Lite no power on eBay for practice. I plugged charger - 15v 0a.
I found some liquid damage around the MAX77812 IC, cleaned it and found short around the IC (2 capacitors 10uF 0603 and 4 capacitors 100nF 0402).

My next steps were:

  • removed the IC - still short
  • removed 4 100nf 0402 capacitors - still short
  • removed 2 10uF 0603 capacitors - no short
  • soldered new capacitors and the IC - no shorts.

I plugged a charger - 15v 0.4a, the battery started charging, but the console still no power, so I tried how charing works, battery voltage at start about 3.8v - 15v 0.4a, then 3.9v - 15v 0.3a, 4.0 - 15v 0.2a, 4.08 - 15v 0.1a and charging stoped at 4.13 - 15v 0.0a.
I plugged another battery and it charged as well.

I re-check board: no liquid damage, no shorts.
What should be my next steps?

Capacitors that I wrote

What exact resistance to ground when you say they are shorted? Those area have low impendence to ground which most beginner misunderstand them are short to ground

Show the actual picture on Max77812. Most case you have to either reball or replace the chip. Cleaning might not be enough if corrosion remains under the chip

1 Like

I soldered a new MAX77812 and new capacitors

ok, then check voltage around max77812 inductors

if you have top 0.60v, right 0.65v meaning boots to stage1, if you eventually have 0.61v on the left, your s-lite boots fine.
TOP,LEFT& RIGHT is mentioned as normal orientation, ignore the orientation from picture I took


Still provide the resistance to ground where you think it’s shorted.

Replace all capacitors with blackened end caps as they look fit to fail later and polish the unpopulated inductor pads to ensure no carbon burning going on in the board and layers.

I have 0.0v on inductors around max77812

check you daughter board long flex both side continuity. If nothing wrong with power button and backlight flex, you may have issue on m92 or other standby voltage before enabling max77812

1 Like

Daughter board and other parts are known good.

I have three m92 chips, tried all of them - charging did not trigger 5v or 15v (nothing happened when I plugged charger), so I returned the first chip and now charging doesn’t work, but it triggers 15v.
Inductors around max77812 - 0v

Also what is the resistance to ground on all your primary rails?

Your readings are fine afaict

but, if this is your most recent install and your image, then the chip you’ve installed is bad (look at the chips all over it) and is off kilter/wonky. If yours, you’ll need to replace the IC.

If it’s not your image/install. Were you getting voltage on the surrounding inductors folowing prompt to boot prior to replacing the IC?

It is my board. Yes, the chip is definitely broken. I have ordered a new one.
Thank you.