Switch Lite Wont Charge

So I have a Nintendo Switch Lite that had a broken USB-C port and a shorted M92T36. I soldered a new USB-C port and M92T36 chip and the short is gone, but still… no power and it wont charge with the OEM charger.

Before doing the job, I tested the USB-C with a breakboard and all values were good (compared to a working NS Lite) except for pin CC1 and CC2, which should read 0.538 (Diode Mode) and I was getting “0.000”. After installing the new USB port and M92T36, it keeps reading 0.000.

I tested for continuity from pin CC1 and CC2 from the USB-C connector all the way to the M92T36 which pin #35 is CC1 and pin #37 is CC2. There was continuity. I tested in Diode mode too and was getting 0.000 again.

Checked the fuse and charged the battery with another working console an both are ok.

Checked bq24193 for shorts and theres no shorts.

I don’t know what else should I do next.

Also I want to add that while changing the M92T36, I damaged a small resistor that connects to the pin 22 (S2_DRV_SRC), but I don’t think that is the problem since the issue is the same since the beginning and now there’s no shorts. I used my thermal camera and also didn’t see any hot spots.

Check fuel gauge. Sometimes gets knocked when changing the port on a lite

Does the NS Lite have a fuel gauge? I think that the original model does, but not the Lite.


Thanks. Is there. No shorts on the caps around it.

Do you see 4v at the highlighted test pad behind the lipo connector?

Yes. It reads 3.4v which is in the range. I connected the Charger, turned on the switch but it’s not charging so It turns off quickly. Already tried to reflow the M92T36 chip with no luck. also I tried to charge it with both sides of the charger cable to ensure that both set of pins were properly soldered to the PCB.

are you seeing signs of the board booting when you plug in with the charger with a battery connected? Have you tried replacing the bq chip which sits just west of m92?

When I plug the cable, nothing happens. I charged the battery with another switch lite and then I put it back. When I plug the cable, it doesn’t charge.

I haven’t changed the BQ Chip cause I checked for shorts on the capacitors around it and none where shorted.

By “nothing happens” do you mean you dont see anything display on the switch (such as a battery charge symbol or a nintendo logo), or do you mean your ammeter is coming up blank? If you have an ammeter you should be able to tell the device is booting because the meter should blink off and on again as well as the current draw dropping and increasing past .47a.

One thing ive learned from people wiser than me here is that just because no shorts are evident does not mean the IC is still good. It is possible the IC has a fault but is still in a state that doesn’t cause a short to display. Do yourself a favor and take some resistance readings on all the passives surrounding m92 and BQ and then compare to known good readings to see if yours are in spec.

Lastly you can always plug the battery in, hook up the usb cable (or hit thepower button) wait a second or two, then use a bright flashlight near the edge of teh screen to see if you have display. If you can see the home screen with the flashlight, then you have an issue with your backlight somewhere. I am also assuming that you have hit some buttons or tapped the screen and haven’t heard any noise indicating you’ve booted into the OS?

I have an ammeter but only works with 5v, so it won’t work with the OEM charger since its 15v. Anyway… When I plug it, it draws 0.002A. That’s nothing.

There’s nothing on the display, no charging symbol. As I said before, I charged at least 5% of the battery using another switch and the display works. It boots to the OS home screen without issues, but doesn’t charge.

So I measured all the capacitors around M92 and BQ, but the forum wont let me upload the image. Tried uploading it to an external host, but the forum doesn’t let me include links neither. :unamused:

1 Like

Have you checked the coil and the fuse for continuity?

Yes. Coil and fuse has continuity.

Okay Hard to Tell, I guess it’s either BQ or the Fuel Gauge, or a Problem with the usb Port.

@Severence what Do you think?


I would imagine this is the primary issue atm. I would remove the M92 IC and see if this short clears, if not, might be worth removing the USB incase it’s causing it subsequently. - in other words, retrace your steps, only logical :slight_smile:

1 Like

The short disappeared after removing the old M92. So I installed a new one, still, there’s no shorts now, but the problem still exist.

Also, I have a noob question. When I was measuring the resistance of the ceramic capacitors around the BQ IC, there’s one that reads 44 kΩ but if I swap the probes, it then reads 10 MΩ. Is this normal?

1 Like