Switch not booting up

Hello everyone,

as of yesterday, my 90% dockused Switch aint booting up anymore.

When i plug in my voltmeter, i get 5v at 0.45 amp.
I´ve tested around all common problem areas liked M92t36, p13usb and bq24193: no shorts found.
I also tested filters and fuse: no shorts to ground found.

The cap´s, which usually mean a shorted CPU have no short to ground either.

What i find odd is a cap next to MAX77621 which i dont have a ground peep on either side at all but from what i found via google, that area has usually a low resistance to ground.

I put it in the dock and the dock flashes for a second and never shows up again. My sons Switch works fine in that dock so that can be ruled out as well.

Before i order replacement chips for either i´d like to ask what else i could test to rule out a fried cpu?
The CPU gets warm to the touch, when i let the power plugged in.

Part of the issue with the M92 chip is that a lot of the time it apppears as normal, as in no shorted capacitors around it. Unfortunately the only fix is to replace it and see if it makes a difference. It seems like quite a weak IC from my experience. I would also check the filters around P13 and have a look at the charger port for good measure. Karl

So despite no error around the M92 chip it can still be dead? Nice.
I order the 3 chips.

I got it to show up for a few moments with the old battery and it showed a bluescreen.
I guess that means cpu problems?

The chargeport was replaced 2 years ago and ever since it hasn´t really left the Dock. Could it still be faulty again?

Too bad there aint any repair shops for Nintendo Switch near me anymore else i wouldn´t have to ruin it even more.

yep, when it comes to m92 and wonky voltages, just assume the chip is either dead or if you just re-worked it, is still needing some adjustment.

doubtful, but always a possibility if other fixes aren’t working. If the port isn’t loose in any fashion, is not damaged, and all legs appear to be solid you’re probably ok here.

oof, bluescreen is almost always bad ram or cpu. There is a chance that you have a bad solder joint underneath either and a reflow MAY solve it. Generally, from what I’ve seen, BSODs on switches have a much higher percentage of being no fix.

Hi Coda, thx for the input.

I´d go for the following way:

  1. replace USB Port since the plug is rather loose in the port
  2. replace M92t36
  3. replace BQ24193

If still not working
4. replace P13USB

If that all doesn´t fix it, i´d say the switch is done for and needs a replacement board.

Focus on the blue screen issue before anything else. If it has been docked for the majority of its use it may be possible that heat build up in the CPU may be the cause of your issues as the switch has to work a lot harder when docked. Maybe a re-flow of the CPU or Ram chips (both) may help but from my experience the blue screen issue can be a bit of a pig to resolve. I have just invested in some specialist re-balling tooling as I have had no luck personally with just the re-flow. It may work for some but never has for me. Karl

Hi Karl,
ok i think i can pull off a reflow after watching a few videos, actually doesn´t look that hard.
I know, not looking and being hard are 2 different things.

I still will replace the port first since its bothering me for being that loose in there. not that its as simple as that and i ruin my switch even more cause it was just the busted Port.

Since the Dock flashes green for a moment, i guess i´ve good chances the cpu aint fried?