Switch Not charging, NEW M92T36 and BQ24193

ibb co/dPS74YJ
How can I upload an image ?


Bought switch that didn’t charge.
Port pins were bent, so I replaced it, then It was taking only 0.002-0.004 amps.
Found some shorts above the M92T36, so I replaced it.
No more short around it now.

Bend few pins on LCD connector, replaced it.
New battery, console turned on all the way but not charging.
Battery went from 50% to 40% in 10min. Maybe because its new battery.

When plugged in, one side is showing that is charging, but not taking any amps.
With the other side of USB it’s not showing charging icon.

Replaced the BQ24193, still nothing.

Thinking about replacing PI3USB, but it looks alright.
Also, I damaged the 10nF 25V 0201 next to M92T36, so I just bridged it.
Any thinking else I could check ?
I have read that there is some kind of charging protection or something.

Any help would be appreciated,

Maybe I get you wrong, but I think the cap in this spot is used as bypass for overcurrent during pluging. If you bridge this cap you short your power supply direct to ground.
If this cap is not in place it will not be the cause of no power. The Switch can start without this cap.

imgur com/IHWK9ml
I have bridged that one.


Thats the voltage im getting, im using 5v charger. Will get fast charger when I fix it :smiley:


As on this one I should be getting on M92T36 PIN 6 3-6v im getting nothing.
Would the M92t36 be faulty or its because I bridged that as on the previous picture?
I have order that 0201 cap from China, 1000 of them. Will take week or longer.
Do I need it, can I just unbridge it ? Is it just for smoothing out or something ?

On the ic side of the cap my reading is 5 V on the other side 10 V. I m sure that the bridge is not helpfull.

Correct, just removed the bridge and its charging at 1.15amps.

Didn’t know how the caps are working, so watched few videos about them :smiley:

Thanks guys, I think It’s all solved now.

I paid like £40 for that switch, plus the parts about £30.

Its fixed.

When replacing the M92T36 I moved one of the tiny caps on bottom right, and when I tried to move it back I broke it.

It ought it was good idea to just bridge it :smiley:

Removed the bridge and its working.

But the FAN didnt work, so removed like diode next to the connector and its working.

Also, the Memory was getting hot and battery was going fast, I think removing that fan diode helped or by removing some debris from the old LCD connector that went under the memory.

Only thing that dont work its that you can charge with one side of the cable not the other.
Will one side be enough for the DOCK ?

Maybe you are lucky, but I guess, if the visible pin row of the usb connector is correct soldered there is a problem with the hidden pin row.

1 Like

I can’t understand why bridge capacitor pads, they are not meant to be contact in DC line, so you bridge it, the dc current goes to ground and you create a new SHORT.

only try bridge small value RESISTOR not Capacitor

I cant understand to, I’m a noob. Just learning on the go.

1 Like

Is it nessessary to replace this 0201 10uF cap near the m92t36 ic chip?20210215_095105|566x500

No, it is a bypass cap. Without it the Switch should start.
But it should be in this line to help grounding overvoltages and static charge due to connecting the powersupply to the Switch.

So…i’ve replaced the bq24193 chip.
Now the problem with this error code (2101-0001) is gone, but the new problem is, that the switch starts only with ac cable and only till the nintendo logo appears…then the console shuts down or black screen i dont know.

Only chip i dont raplaced yet is the pi3usb on the back side, but its not showing any damage, there is no short.

Usually the most common issue for this problem is when you reflowed the BQ chip, you ended up heating up and shorting out the fuel gauge behind the battery connector. You might need to replace that chip.