Switch not powering on fully

Quick bit of history. I bought the switch off ebay, was completely dead and drawing no power. I reflowed BQ24193 and M92T36 and it began to charge, however still nothing on the screen. I replaced P13USB and got the switch fully charging, booting, running games etc. However it would not recognise a USB connection or connect to HDMI (although it would go black screen like it was attempting to).

To try and resolve the issues I then reflowed P13USB and M92T36 again and now the switch does not boot at all, when i press the power button I get the backlight for a few seconds and then it dies again and it constantly draws 0.45 - 0.46A from the charger

I have put a new BQ24193 on it as I had one spare, and I have tried another M92T36 (although unsure if it was working or not).

What would be the next step to try? Order a new M92T36 or is it possibly something else on the board? I have tried searching for shorts and can’t seem to find any. Also the switch does the exact same with or without P13USB on the board so I think i’ve eliminated that

Thanks

On second inspection I’ve just found that there’s a load of shorts in the caps below the emmc beside the CPU. Im assuming that means a dead CPU?

Can’t understand how it’s went from reflowing M92T36 to a dead CPU though :thinking: