Switch not turning on Big Mystery

Hey Everyone, I am in a really strange situation that I have not encountered before. I bought a broken Nintendo switch and it is not turning on at all. Things that I have tried:
Try a working battery to turn the Switch on. Did not work
Tested all capacitors around the different chips on the front and back of the motherboard. There is not one capacitor shorting.
Therefore I am out of options, as I do not see any strange things on the board. None of the chips seem faulty based on the fact that I havent encountered any shorts.
Checked the screen ribbon cables, but they all seem fine including the backlight.
Does anyone have a suggestion? I really want to try to solve this puzzle :slight_smile:
Hopefully someone has any ideas.

Kind regards,

Wow I found the solution. If anyone else ever get this problem and all readings are fine. Capacitors/voltage etc. Then please check if it is stuck in RCM mode🙈 Using a SD card from my own switch with cfw I was able to boot the normal firmware again. Hopefully this could help other people dealing with this issue!

1 Like

+1 check if it is stuck in RCM mode. This has tripped me up before

1 Like

Thanks for the solution,

My switch was in a similar state but I tore it apart before even doing this…

Once I get a new battery in I’ll try this for sure

Hope it will work for you as well! Would love to hear back from you when you tried. I am curious about the outcome :slight_smile:

Hey brother,

Battery came in, boots but stuck on logo still. Having problems trying to install custom firmware

My switch is in the neutral area, potentially being patched: XAW10119+

I don’t know what version the software was, so unsure what payload to inject into the switch

Do you have any recommendations?

Hey, so I am not that experienced at this situation, thus perhaps my advise will not be helpful.

First of, my situation was different. My switch was stuck in RCM mode, I didn’t get a logo at all just a black screen. What I did was injecting Hekate payload and boot to the original firmware from there. In your case this would probably not work, as you already are booting firmware.

Maybe you could go boot in RCM mode and check if Hekate payload will work and from there boot into your firmware, but I doubt it will.

Another thing that could be apparently is that one of the power chips are faulty and needs to be replaced. Perhaps you could try that. I had one switch being stuck at boot logo as well and unfortunately never did solve the problem. Be sure that you don’t have any shorts at least.
Good luck and let me know if you made any progress :slight_smile:

Perhaps someone else on this function has better knowledge of this scenario.

One question regarding this solution. How did you know what payload to inject? I have a switch stuck in RCM mode that was on the chance to be hackable serial numbers. I’ve tried to inject and it says payload injected successfully, but nothing on screen. Idk if I should be trying a different version or what, but I’ve had no shorts in places where they shouldn’t be (though there was one to the left of the lcd connector on the Mobo, but I couldn’t find anything on it so I assume it was normal.) Is the SD card strictly necessary to inject Hekate?

Following injecting a payload does tegrarcmgui report 0x7000 in the log?

It’s necessary if you want the GUI version of Hekate (with the files on SD)