Switch patched V1 boots up, docks fine, but black screen in handheld

Hi.

I tried installing the hwfly v4 chip and it went good, the chip flashed and did it’s job, but when i was powering on the device i noticed that the switch’s screen wouldn’t turn back on.

I’m a novice to soldering, but the soldering did look very neat for my eyes. I have ordered microscope, but couldn’t really bare to wait, so i went on and did the install.

I tried all sort of things with the chip installed and eventually just decided that i’ll have to wait with the install until the microscope arrive (lmao). So i removed the modchip and the switch will not turn on the screen… Any ideas?

The back light is working and i can see the light on the backside of the switch, switch turns fully on and can navigate with black screen and when i dock the switch it works normal…

I’ve checked that the voltage to LCD driver is corresponding to 5v, and looked all fine. I checked the ribbon cable to lcd cable and can’t see any damage. The screen has worked fine earlier, just unpatienced me that couldn’t work, but i’m very eager to learn!

did you inspect the connector itself for any bent or out of place pins, have you inspected the latch for any type of damage or misalignment?

Does the switch still respond to touch input while in handheld mode?

Hi, thank you for taking time to help me out!

Yes, i’ve checked the connectors and to the naked eye, they seem fine, also tried cleaning the connector and pins, also re entering them properly to the connectors.

The switch responds like normal to touch input.

well, while you might feel your naked eye is good enough for inspection here I think you should take the time to use something with magnification to look at that FPC connector. Even a cell phone with a good digital zoom would be a better choice. If your backlight and digitizer are both functional my guess is still an issue with the fpc connector. These things are unbelievably fragile and it is very easy to damage a pin, even if you’re being careful. The cable should slide in straight with minimal resistance, if you’re having to rock the cable back and forth or use more than a small amount of force to seat it, those are all signs a pin is not in the right place.

The only other thing you could possibly do is put a little pressure on the connector while its powered on, jif the display comes back to life you know have an issue with the connector. However, keep in mind if you DO have a pin out of place you do risk potentially creating a short and causing damage. I would exercise a lot of caution and do your best to verify everything is in its place.

All else equal, you should be able to get this one back and running with little effort seems like. Do your best to get a better view of that connector and let us know whats up :slight_smile:

I’m having a hard time how I could’ve possible damaged the fpc connector as when i did the modchip install i did not remove or touch the ribbon.

Although I’ve checked it a couple times and cleaned it up, I’ve noticed that it doesn’t go directly in and i use a little tweezers to pull it in, possible that could actually be the case.

As I have had i powered on before multiple times i assume that if i’ve had a short it would’ve caused damaged already so I tried powering it on and pressing on the connector and a little force on the ribbon cable and it did not help unfortuanetly…

I’m currently waiting for the microscope since that will make this fault finding a whole lot easier. The microscope should be right around the corner :slight_smile: I’ll update you for futher findings, thanks a lot for your time and good guidance, I hope this is the cause for my screen not working.

Here’s some closeup I took from the board with digital zoom on the phone. It does look like the fpc connector looks fine on the pins, I need to double down on that when the microscope arrives, damn it.

BUT, I can see that the lcd ribbon cable itself got scratches, I’m wondering if they are super venerable and how I would go on about to check it, if anyone can measure proper values or for continuity within the cable?

it does not seem like your images are available to look at