Switch stuck on charge screen....even with "known good battery"?

I seem to be having an issue that I cannot find the answer to. I’ve read through what I can find on this forum and watched through all of Steve’s videos again but I’m still not sure. I’m not used to posting things so I’ll try to give as much info as I can.

I’ve been working on a Switch that I thought only needed a replacement charge port. The seller I purchased the unit from said that her kids were using it and then one day it wouldn’t turn on. Figured the battery just finally ran out and would just need to be charged up. Well, I got the charge port replaced and as soon as I plugged it in, the Nintendo logo popped up and then went to the black charge screen with a red battery and a lightning bolt next to it. I assumed it was just depleted and needed to be charged overnight. WRONG! Next morning the battery indicator was still red, and as soon as it was unplugged the Switch just turns off. I though ok maybe the battery is bad, so I plugged in a “known good battery” and the same thing happened! Nintendo comes up, then right to the charging screen saying it’s dead.

It appears like its slow charging at 0.41a, but never actually charges? Or isn’t recognizing something? I’ve tried several batteries. I’ve replaced the M92T36 chip and there was no change. There doesn’t appear to be any shorts around the BQ24193 battery chip from what I can tell.

If anyone has any ideas I would greatly appreciate it! Thank you very much!

Well after doing some more searching I just went ahead and changed out the BQ24193 chip…with no change :roll_eyes:

Try to turn it on with an externally charged battery and see what happens. Check for shorts in the capacitors near M92, PI3USB and BQ.

Thanks for your reply!

There is no change with a known good battery…and it shows that the battery is depleted even when I know it’s fully charged. The M92 and BQ chips have been replaced with no change. I’ve tested all of the capacitors near those chips and cannot find any shorts. I took it back apart and tested most of the larger and medium capacitors all around the board and didn’t find any shorts. Any other ideas?

Well crap! Now I may have messed it up more…

I decided to try and put the eMMC into another switch to see if I could get anything (I know it wouldn’t boot up but I just wanted to see). Of course nothing happened. When I put it back in to its home switch, now nothing happens. I don’t get a backlight or anything. I checked the pins and they are all ok, nothing bent or anything. So now I’m really at a loss. It still charges at 0.41a, but now there is nothing on the screen. Did I short something out?

To reply to your last post, maybe you just put the backlight ribbon cable incorrectly? I had a shorted EMMC and it shorted the fat capacitor over PI3USB so check that one if you think you may have messed up yours. Mind you, if you have tried reworking some chip and you accidentally bridged some pins, it won’t boot up and you’ll have to rework the chip again to get it back to life. Happened a few times to me

If you put a charged battery and it doesn’t power on it means it’s more than just charging problems. Maybe check the coil to the right of the USB port? Maybe check the pins of the battery connector?

Also I would try again an overnight charge, this time with the good chips on. Maybe it will work this time

Ok so I took it back apart…the capacitor by the P13USB is not shorted. I’ve also checked all the filters below it for good measure and they all seem to be fine. Rechecked all the capacitors near the other chips and there are no shorts I can find. I took a few pictures with my cheap microscope of the M92 and BQ chips I replaced…I personally don’t see any bridging and everything looks ok to me (not that I’m a pro here):

M92:

BQ:

I don’t think its the ribbon cable but I checked it anyways and it appears to be fine. Also it had been working right before I took the eMMC out. So I really have no idea. I checked the coil next to the USB port and it’s fine. I rechecked my connections on the USB port itself and they are all stuck in place. I’m assuming that there is some short someplace that I can’t seem to find. I’ll let it charge up and see if anything changes.

I appreciate the help!

I’m out of ideas, maybe it’s wise to wait until someone with more experience chimes in. The only thing I can think of is maybe reworking M92 just in case, although I see no red flags in either pic

Thank you for your help anyways…I really appreciate it! I’ll keep working at it but I’m out of ideas.

Just as a point of curiosity, did you ever turn it off while it was plugged in charging rather than letting it sit on the battery logo?

Yeah I forced it to shut off by holding down the power button and let it charge overnight. Still no change :roll_eyes:

Hi,
an other idea: what if the fuel gauge MAX17050 on the backside of the battery connector is bad and communicates a faulty state of charge?

Well you may be on to something here…

I checked to see if anything was shorted around that chip, however nothing seemed shorted. Have a look at this though:

Now here’s the same chip on another board:

I mean I’m no expert but that looks to be blown out or something! Unless that is normal? Also, it appears that I’m missing some sort of capacitor not far to the right of that chip:

So it appears to me that something blew, maybe because the pins in the usb port were all mashed together before I replaced it? The only issue now is I still haven’t been able to get the screen to come back on, and I’m not sure this would have anything to do with that. Or maybe it would? Also not sure about how to replace that type of chip.

This does seem like it may be one of the issues anyways. Thank you for your help! I really appreciate it!

switch cannot boot if fuel gauge ic is defectuous , fortunately its a very easy one to replace , only few pads

The fuel gauge IC is a WLP with 3x3 solder balls underneath. It looks like an easy hot air job.

In this damage state I would more expect a missing signal than a short.

The missing cap from the third pic shouldn t be a problem because there are three additional caps which make the same job.

Ok I managed to get the chip off!

Your right came off pretty easy. Was going to show what the chip looked like off but it went flying from my tweezers and I haven’t been able to locate it :roll_eyes: Now I just need to find another one…

Thanks again for all the help!