Switch that has a video signal in tablet mode but not in the dock

I have a nintendo switch that gives video signal only in tablet mode. In the dock no image on TV. I changed the P13USB for the first time with a new one, I fortified all the capacitors so that there would be someone in a short time, including the filters next to it. Moved again and put in the dock the same problem. I mention that I have another switch that gives a video signal on the TV in the same dock. I also changed the M92T36 and the same result. In diode mode I measured by comparison with a good board all the parts around P13USB and M92T36 and I have good values. I also measured the connection of the USB-C plug on the motherboard for all pins and those visible and those behind. Everything is ok but it doesn’t show anything on the dock. Only Automatic and 480p appear in the console menu at TV settings, which is not normal. I got stuck here. Any idea to save me? Thank you very much and sorry for my English

Did you checked the internal pins of the USB C port?
The other resolutions in the settings menu will appear when it can dock. I had a fully functional switch that i repaired and after an hard reset the only option was 480p after the first dock the other resolutions appears.
This was the problem in my case…

It was simple if that was the case. I checked the internal pins of the USB C port.

I used USB Type C Plug Breakout board, for testing the USB-C port on the Nintendo Switch. Allows testing of all USB-C pins, if they are right soldering on the logic board.

Ok, you are sure that the hardware is ok right?
So maybe it can be a software problem, do you already tryed a hard reset?

I think you are joking. A hard reset does not solve this problem…never. The problem seems to be under the Tegra SoC. Tomorrow I will do a reball and come back with new news.

I see that you already have all the solutions, good luck!

As I suspected, the problem was under the Tegra SoC. Taking it down and reballing solved the problem. I hope my information will be helpful to others.


Excellent job! Just out of curiosity: did you find any bridges or faults under the SoC that caused the no dock signal?

1 Like

Thx Bro. I did not find anything visible but more than likely it was oxidized balls, or balls that lost contact with the motherboard.