Switch USB replaced but won't connect to tv

This is our first attempt at fixing a switch, so new to this. Bought a switch off ebay and the pins in the USB port were mashed so we replaced with a new port. It successfully works now as a standalone unit. Charges great, everything else works. But when you put it in the Dock then we get a green light but no output to tv.
Tried connecting to the computer via USB and it is recognised both sides. Tried to check continuity and from what I could see there were no shorts? Any suggestions on what to try next?
Could it still be that we messed up putting on the new USB? It took us a while with the hot air to get the old one off.

Forgot to add, we tried it in a friend’s dock and it did the same thing so confirmed its not a dock issue.
When placed in the Dock the screen goes blank and when you push the buttons on the joycon we can hear it moving through the menu but nothing on either the TV or the unit screen.

Are there any shorted caps around M92T36 or P13USB? Also be sure to check the filters on the output of P13USB