USB-C port charges one side only

Hi TronicsFix and fellow members,

I was viewing your video from youtube “ttps://youtu.be/Xix7qzbOT6Q” dated on 7 March 2020 - (I bought 23 Nintendo Switches …) and at 08:47 while testing, charging of the console was verified by inserting both sides of the charging port. It was mentioned that there are some problems that could result charging one way and not the other way
I am currently facing this problem with one side of the port charging and the other doesn’t. Tried other chargers but it didn’t work as well .
What is the exact problem? And what should i be looking out for?
Thank you

How do the pins look on the charging port that the ac adapter plugs into?

The pins look good to me. Didn’t seem to be damaged.
Other than that, what other possibilities could it be? Like the power ic chip m92t36?

Hi all,
Found out another problem as well.
I was trying the Bluetooth adapter Gulikit Route Air to see if it pairs with my wireless headphones at all but there is no power from usb to power the BT.
To date, 2 issues

USB C Cable can only charge one side but not the other side
Bluetooth Adapter is not functioning anymore.
Any IDEA? Appreciate for any help

You would have to test for shorts, could be the PC13USB IC. Have you tried it in your dock? Do you get video in your dock?

Docking is 100% fine. Tested already.
But I realised image will only show on using at one side of the usb c, nothing happens when I flip the other side. Same result as my charging problem.

Do you use a friend messenger

Hi bro,
are you referring if i have a facebook messenger?

@frost

Did you make any progress? I would suggest that the M92 is damaged and probably warrants a replacement. It does all the USB Type-C port marshaling including providing VCONN which is sent back down the wire from the switch to power USB peripherals. One-sided charging is also a symptom as this chip handles the orientation of the USB Type-C plug and informs other parts of the system that rely on it (PI3USB).

If you can change that, let me know how you get on.

I’ve identified the problem on my end. Turns out the CC lines go through an ESD protection device on the underside of the board. This had failed and was killing the CC orientation signalling from getting to the M92. Having removed that last night (it’s not fitted on some versions of the board), I was able to get the switch to charge on both sides of the connector.