V1 no stage 2 boot, NAND working via RCM->Hekate->ATM/OFW

Son did update and switch never booted up again. Don’t know what OFW he started with and what updated to.

Initially could not even trigger RCM unless disconnect NAND->connect battery->RCM->Connect NAND. Hekate->OFW show it was 16.0.1 Fuses show 13.2.1 - 14.1.2 max. Can run games fine.

Eventually built a few OFW in NAND. 17.0.1 will power up to RCM without needing to disconnect NAND first. So presumably no stage 2 boot.

Tried updating in OFW but reboot goes to black screen. Need to do NAND disconnect->Battery recoonect->RCM->connect NAND trick to inject Hekate. Launch OFW from Hekate stops and show pkg1 20240207… which is 18.0.0 so need to wait for Hekate update.

Hekate boot of OFW 17.0.1 works great. Everything works including dock. Any idea why OFW can’t boot on its own (presumably can’t boot stage2)? Have check for shorts everywhere and not found. Checked boot stage 1 voltages and seems all good.

Tried OFW 13.2.1 and 14.1.2 (per switch fuse pattern) No difference.

Originally posted on gbatemp with more details (post #1/#3) won’t let me post links here so google “gbatemp v1 unpatched only boots ofw if” to find thread.

Did have no sound and won’t dock initially but after 1 night of leaving Hekate booted OFW 17.0.1 in sleep on charger (battery was fully charged before) both magically worked.

Update, OFW 17.0.1 is same as all others. Can not trigger RCM after plugging battery without first disconnecting NAND. I mistakenly thought 17.0.1 did better than others but Auto RCM was on…

Anyway, this switch’s problem are

  • OFW can’t boot on its own. Can’t trigger RCM after battery connect (have to do the NAND disconnect->battery connect->RCM->NAND connect trick)

  • Fuse patterns are old. Presumably because can’t boot OFW on its own.

Other than this, works perfect. Just need to launch OFW from Hekate.

A bit of an update. Turns out CAN enter RCM mode even after replugging the battery with eMMC connected. It just takes much longer (say 20s?) I guess need to fully shutdown something (BOOT1?) and cold boot to enter RCM?

ok got everything to work properly rebuilding NAND to 14.0.0. Looks like not a hardware issue but latest OFW update (18.0.0) causing bricking problems. 17.0.0 also cause bricking problems as well. See bottom of post #3 on my thread google "gbatemp v1 unpatched only boots ofw if” for more details.

Fixed, Reflowed SOC+DRAM

google “RCM switch cannot burn” for post near this timestamp.