VCC_2V9 LD06 not present


I have a non working switch, backlight for one second and then nothing else.
I tested everything.

I start motherboard from bench power supply, only thing I noticed is that I do not have VCC_2V9 according to this picture.

Any help appreciated!

To complete this post, I tested in diode mode and found these strange values.

127mV and 70mV together are not possible. Your measurements are all on one line (Vsys generated/switched on by BQ ic) and should have one value.

Here are some spots where Vsys appears and where for example a failing cap could draw the line down. The map is for a Switch V1.

Oh you’re right I probably mis typed the 127 value, will check again.

Thanks for the diagrams, I will check if something is wrong on VSYS line, but voltage of VSYS is 4.2V. I add that battery does not charges, don’t know if this helps.

So I triple-checked, and don’t know what I’ve done bad yesterday. I have correct readings all around MAX77620A.
I checked VSYS diagrams on both sides of the boards, readings are also correct.

I’ve just seen I have an amp draw of 0.4A @ 5V.
It seems a bit complicated to resolve isn’t it?

Unfortunately cannot edit previous posts, sorry for the numberous ones.

I tried to TegraRCM, removed EMMC, RCM OK so I tried to inject payload.
It works, but screen stays black.

Is it a unpatched Switch?
If not, it is normal that the screen will not display something because the payload is not executed on the Switch.

It’s a patched one. While injecting, I have 0x0000 so this means it doesn’t work?

If the Switch is patched, the payload will not have an efect on the Switch.

But does it means something if RCM is ok, but I have not used any RCM activator?

At least this switch have some signs of life?

If the Switch is recognized in TegraRCM without previous forced into RCM mode, the Switch has a problem.
If you unplug the emmc module a Switch will go automatic in RCM mode.
So my guess is that there is a problem with the emmc module.

It goes to RCM mode without emmc.
If I plug emmc it is not recognized by tegrarcm.

What is the story of the Switch?

This is a V1 unpatched, I replaced P13USB some months ago due to a no power, and LCD connector due to a bad insertion of the ribbon.
Then it worked perfectly for around 6 months.
Now this switch does not power again, no charge.
There is a consumption of 0.4A @ 5V, cannot check consumption at 15V.

So I checked MT92, BQ chip, P13USB, everything seems good, and found a missing voltage at the MAX IC, 2.9V.

But that’s strange as diode reading is correct (0.569V iirc)

Sorry I can not follow… now it is a unpatched V1?
Did I missed something?

I made a typo error, I mean patched, sorry!

Ah, ok. :joy:
The charging ciruit should work even if the SoC is damaged. I would check the voltage of the battery with and without usb charger plugged in.

Battery voltage disconnected: 3.787V
Battery connected: 3.785V
Charger plugged in: 3.841V

I didn’t noticed that but it seems to be extremely low charge, 1min after I have 3.845V.

The charging voltage (charger plugged in) should be 4.2V.

VBus is your input voltage deliverd by the charger 5V or 15V.
I would check the voltages and look after the fuel gauge on the backside of the battery connector.