Weird touch screen issue after replacement

I have what seems to be a very weird issue after replacing the touchscreen. The old one was working fine but badly scratched, so I decided to replace with a new one.

After installing the replacement, the new TS was only partially working - only the left/right sides worked. I temporarily replaced with the original, which worked fine. I swapped out the game card/ts board with the same results, old worked but new did not. Nothing weird so far, must be a bad replacement, but I tried 2 more from different sources with the same results.

Now here comes the weird part, if I boot up the switch with the old TS and then swap to the new one without fully powering off, the new TS works just fine, all parts are responsive and working. And it I put the switch to sleep and wake it up, still working fine. But if I fully power off or remove the battery, when it powers up the new TS is dead in the center again.

If i then swap in the old TS without powering off, it is now also faulty in the center section. But if i fully power down/disconnect battery, when I power back up with the old TS it is working again.

I have 2 old “original” Nintendo TS’s both badly scratched that work fine after a power cycle, and 3 new TS’s from different sources all which are dead in the center section after power cycle. Tried multiple GS/TS boards with the same results. It is as if there is a way the switch is detecting a replacement TS on power up and not initializing correctly.

Any ideas?

Solved.

I decided to compare the ribbon cables between the original TS and the replacement and found one difference.

On the original there is one trace that is connected to ground that is open on the replacement. It looks like these pins 12A, 13A and 12B (my numbering) are used as some kind of identification, either being left open circuit or shorted to ground (pins 11A, 14A, 11B & 13B). To test this, rather than trying to solder on the ribbon cable, I took a look at the GS/TS board and found these pins were accessible from some vias.

I added a wire from 13A to ground and voila the replacement touch screen worked first time.

Not sure if all replacement touch screens have this missing trace or I just got unlucky, but now here is a fix for anyone else who might be having this problem after replacing the touch screen.

I tried to include pictures but was not able to include them with this post?