Won't read discs, new driver didn't help

My PS4 got worse and worse at reading discs, until it wouldn’t at all anymore (like 3-4 hours of it making a “chuck-chuck” sound, and still not recognizing the disc or saying it was a non-supported type). Thinking it was the disc drive, I replaced it with a drive purchased on eBay. This is listed as a new Sony drive, and the company supposedly tests prior to shipping. The new drive didn’t do any better. I actually did a full initialization with system software reinstall, and this also hasn’t helped. What other possibilities are there? Should I try putting a new laser in my old drive, on the off chance the replacement was also bad? Or is there another likely culprit?

Did you move the daughterboard to the new drive?

There’s no daughterboard on the 1215A drives. But just in case, I got a new laser and put it in my old drive. Reinstalled my old drive and still not reading discs.

Oh, I didn’t realize it was a 1215. My only other guess is to check components around the disc drive to see if they failed.