Working out which emmc goes with which board

Morning all!

So I managed to grab some boards for very cheap. They were listed on ebay as basically unfixable, but along with 11 untested gamecard boards. So for £40, that seemed like a win.

In all of it there were 3 normal switch boards, one was clearly already used as a parts board and was missing all sorts of things. But the other two were less clear cut.

Of these board A had a number of things missing, but nothing major, just some passives near the common problem chips, and also the LCD driver and SD connector. But on putting back all the passives and reflowing the USB I was able to get into RCM and inject a payload. This seems fixable, so I have ordered an LCD driver and SD connector so I can get it working.

The other, board B, was in similar condition but missing M92 and had a damaged fuel gauge. I replaced the passives again, and got it in to RCM, but it is patched.

So this leaves me with the situation: I have 3 emmc boards that were not connected to their motherboards. I think the way forward for board A is to get a display and sd-card working, extract the keys and then try them on each emmc connected to a PC to see which one it works on.

But how can I work out which of the remaining emmcs goes with the other working board? Is there a way? Or do I just have to pick one at random and hope that its either correct or on the same version?


I think at this point the seller has most likely connected the incorrect EMMC modules between all these boards, so chances are high that atleast one if not all have had their fuses burnt as a result of OS/FW mismatch, that’s assuming of course they aren’t all on the same OS version. So you don’t really have anything to lose by trying. As for figuring out which EMMC module goes with which board, if they’re patched you’ll need a modchip, otherwise it’s a guessing game, I have found no info tying the QR/Bar code (sometimes stuck on the EMMC) with the mainboard…

Without a modchip, best you can do is look out for flux pattern on the board and see if it lines up with whats on the EMMC shield (if there is one at all) or if there is rust/corrsion which lines up.

You can of course also check the EMMC data in NXNandManager to get the OS version, if for example you had two on the same OS version then you know you should be able to get two working…assuming no other faults and failing that, you know the EMMC’s don’t belong to any of these boards and likely come from another batch of donors

1 Like

Yeah I thought that might be the case… one of the emmc modules has lost its shield completely, so I will assume that’s from the worst board for now and go from there!

Just to add, you should start by trying all the EMMC modules in your unpatched board first and take that one out the equation, then you might get lucky with the other two’s OS version being the same :slight_smile:

Yeah, that was basically the plan. I was going to check the keys on it first, though launching through hetake and updating probably works just as well.

What happens on a fuse mismatch?
Will it Boot into RCM or stuck at boot Logo or something else?

Just a blackscreen, You can still boot the OS via Hekate (if it’s unpatched) but no standard stock boot. If it’s patched/Mariko you’ll still get RCM but obviously not much can be done without a modchip

Is the backlight on then? I assume the amp Meter will show 0,46A?
If it’s unpatched, I can install a new Firmware and it will work again?

If that’s what happens when in RCM mode ordinarily (I forget) then I imagine it would.

Whatever charging current you’d get (on a known good) with the EMMC removed is what you’ll get here.

If you have the keys gotten in conjunction with the boards original EMMC yeah, otherwise not really

I mean if a wrong EMMC where put on the on board and caused additional fuses to burn, I can Flash a New Firmware then on the original NAND to Match the fuses again?

not a new FW, you’d rebuild the FW using the correct keys ensuring the OS version matches the fuse count and all will be well again… or a simpler solution is booting into the OS with Hekate (which bypasses the fuse check) and update the OS from there… or you’d boot into the OS and use a homebrew tool to update the OS

1 Like

Hello again!
So, I have now worked out which emmc goes with the “working” unpatched board. (And I now have a working screen). It definitely has a fuse mis-match, NxNandManager, says this emmc is running something like 6, but it has 15 fuses burnt (12). I have made a backup of rawnand ousing NxNandManager, and boot0/1 using hetake.

So, trying to run OFW through hetake I get “pkg1 decryption failed” and “failed to launch HOS!”, I am able to launch Atmosphere fine.

I am doing some more digging, I assume I am going to need to rebuild the emmc, but this isnt something I have had to do before.

If you can boot atmosphere, I’d just use Daybreak or Choi to update from within the OS (with your EMMC backup in a safe place)

Thanks! I will give that a try!

Ahhh, damn. Not sure If I did something wrong during the process or if it was pre-existing (though with a corrupt emmc I guess it is likely) but I get error 2124-4517. Presumably perma-banned.
The message does say “temporary” so I guess theres no harm in trying to connect again in a few months or whatever, but I guess this will have to become a personal homebrew machine or something…

I never know if it makes any odds (as it’s very hard to tell if thiese were banned prior or in the moment) but I do the offline update with choi/daybreak or simply rebuild the FW on PC, then, after updating the console I run the RCM version of

GitHub - StarDustCFW/Haku33: Perform a hard reset of the switch

Then I do a full stock factory initialize too afterwards, then connect to the internet… whether any of this makes a difference is hard to say but I do it just to be on the safe side. In your case though, I reckon someone was going online with pirated games and the like, but :crossed_fingers: it’s not permanent.

How do you run the RCM version? The homebrew version seems simple enough, but the readme doesn’t seem to cover running it any other way.