Xbox One no display

Hey! I got this Xbox One from my brother, he said it worked fine until one day it “wouldn’t turn on”. So I took it home, plugged it in, and heres what I found.
The xbox does power on, will accept a game disc, and will play sound as if its working. However, there is no display. I tried force resetting the display settings, and tried using a known working hdmi cable. I also tried plugging it in to two different tvs, both of which work.
I don’t know anything about dismantling or repairing game consoles, so I don’t know exactly whats wrong with it. Could it be a bad hdmi port in the system, or some display module inside the system? Any ideas would be appreciated. Thanks!

The model is “1540”.

Is the hdmi port in good shape inside and outside?

If your hdmi port is good then it’s your hdmi ic chip
Here’s one from ebay if that’s your issue but you’ll need flux and a workstation or heat gun to change it

It’s a 1540 console…

1540 is original xbox one right if so that’s the chip

The xbox one only has three versions original s and x 1540 is just some fancy code microsoft uses on their systems it’s useless outside their offices you can’t identify systems via ebay with it you gotta do it visually it’s probably an attempt to stop people repairing their own systems but they hate people like us who know how to find parts for people

1540 console has no retimer…

Yes they do or no hdmi mate that’s the ic chip every console needs one that runs hdmi or hdmi don’t work

Haven’t seen it… where is it?

The port itself looks good and accepts the hdmi cable with no issues.

You usually need a microscope to find em mate they are tiny

These are possible chip locations but you’ll need to find out for sure a single error will brick the board

So its gonna be easier to just get a new system than all the tools and materials to fix this one xD

1 Like

Probably yeah mate i’d say so

I have the same issue but I actually have all the tools. Would I just have look up each individual chip and replace those or is there a way I can test those three chips circled in the picture like testing for continuity? Cause the chip I have has ten places that need to be soldered unlike the ones in the picture those three has less.

I know this is an old thread, but I had to chime in!

Check the hard drive. Try a different hard drive. If you get an error screen that’s the problem, and I’m 99% sure it is. If that doesn’t work, it’s probably the HDMI port itself, but if it physically looks in good condition it’s unlikely to be the problem.

The original Xbox One 1540 doesn’t have a retimer chip. These were introduced in the One S and the One X to handle the 4K output.

have you checked if there is continuity on the filters below HDMI port… ??